System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Does anyone run a Puppet Node on HP-UX

SOLVED
Go to solution
Ralph Grothe
Honored Contributor

Does anyone run a Puppet Node on HP-UX

Hi,

during a talk about Cobbler, Func and Puppet
at the last "Linux Tag 2008" I heard about these
tools for the first time.
Looks like the RedHat/Fedora guys are using it.
The Puppet tool for distributed configuration management really sounded interesting to me.
Unfortunately, it is implemented in Ruby.
So far not really the fastest of dynamic languages as far as execution is concerned.
Added to this comes the XML-RPC overhead it has been using.
But I think to have read that Puppet's developers want to shift from bloating XML-RPC/SOAP to REST.
Also one usually doesn't find Ruby out of the box on most HP-UX systems.
But this, together with Ruby Gems and Puppet should theoretically be easy to build and install on HP-UX.
Before I delve into it I would like to enquire if anybody of you is running a puppetd on their HP-UX boxes?

http://reductivelabs.com/trac/puppet
Madness, thy name is system administration
6 REPLIES
Solution

Re: Does anyone run a Puppet Node on HP-UX

Puppet in linux works amazing! But no way in HPUX!!!

I've tried for days to install ruby in HPUX 11.23 with IA64 without success... the depot from porting center doesn't work for Itanium I've no way to compile the sources (1.9.1-p0 from Ruby web site and the 1.8.4 from porting center). I'm tired of googling, testing compiler options, etc.

Also, the info in forums, webs, etc. is sparse and hard to find.

is a pity, but I think I'll have to find another way to distribute configurations.
Ralph Grothe
Honored Contributor

Re: Does anyone run a Puppet Node on HP-UX

Hi Sistemas,

I agree, it is a bit embarrassing that these days HP doesn't provide SD depots for their UXes of common dynamic interpreters such as Ruby and Python.
For a while they used to have at least a Python depot in their Internet Express "distribution" but for incomprehensible reasons discontinued the whole IX edition for their HP-UX 11.11 on PARISC.
Although I much prefer using Perl for Unix sysadmin tasks there is a growing selection of interesting Python Tools, such as e.g. Func https://fedorahosted.org/func/

Since one of our customers has a license for the HP ANSI C Compiler I could compile a Ruby installation vor HP-UX 11.11 and create an SD depot of it.
Unfortunately, I haven't found enough time or stamina yet to really learn Ruby (only scratched the surface so far and kept reverting to Perl always :-(

It's interesting to hear someone here in the ITRC forums is using (or thinking about using) Puppet on HP-UX too.
Madness, thy name is system administration

Re: Does anyone run a Puppet Node on HP-UX

Hi Ralph!

Thanks for answer me, the message was so old that I thought had been forgotten :-)

At work we have HP ANSI C license , plus I've installed gcc from the porting center but I'm not able to compile Ruby on IA64.
I tested the original sources of the latest version and the package available at the Porting Center with no success. Doing google search only find japanese pages (blessed translator!!) with no info at all.

The fact is that I have puppet working on linux machines (RHEL 4&5, 32&64 bits) and I don't know how to integrate with python tools. Any help or suggestion is appreciated :-)

Regards, Josema
Ralph Grothe
Honored Contributor

Re: Does anyone run a Puppet Node on HP-UX

Hi Josema,

I also had (a very rudimentary) Puppet master with so far only one puppetd running on two separate RHEL boxes for evaluation and playing purposes.
Next I wanted to run a puppetd on one of our hpux boxes.

I am afraid, since we don't have any IA HP HW with running hpux on it I have absolutely no experience with this platform.

More than a year ago I compiled Ruby from the sources on one of our hpux 11.11 boxes where the HP Ansi C compiler was available.
Thus, it isn't the latest ruby version I suppose.

$ uname -srvm
HP-UX B.11.11 U 9000/800
$ ruby -v
ruby 1.8.6 (2007-03-13 patchlevel 0) [hppa2.0w-hpux11.11]

As far as I can remember I didn't experience any difficulties compiling Ruby back then.
But on IA this might be a completely different story.

As for a gcc compiler,
have you looked at Merijn's (aka procura) site for builds for your platform yet?
http://mirrors.develooper.com/hpux/



Madness, thy name is system administration

Re: Does anyone run a Puppet Node on HP-UX

Hi Ralph,

I've finally been able to compile ruby in my hpux box. I used HP Ansi C and ruby 1.8.7-174. I've also installed the dependencies from the Porting Center (ncurses, openssl, etc.)

$ uname -srvm
HP-UX B.11.23 U ia64

$ cc --version
cc: HP aC++/ANSI C B3910B A.06.10 [Mar 22 2006]

$ ruby -v
ruby 1.8.7 (2009-06-12 patchlevel 174) [ia64-hpux11.23]

These are the options I used to compile (Obtained from https://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1186673):

$ env CC=cc CFLAGS="-g -O0 -D_XOPEN_SOURCE_EXTENDED" \
./configure 2>&1 | tee configure.log

$ vi config.status

s,@LIBRUBYARG_SHARED@,|#_!!_#|-R $(libdir) -L$(libdir) -L. ,g
===>
s,@LIBRUBYARG_SHARED@,|#_!!_#|+b$(libdir) -L$(libdir) -L. ,g

$ ./config.status
config.status: creating Makefile
$ gmake 2>&1 | tee make.log
$ gmake test 2>&1 | tee maketest.log

After that, I've only had to install Facter and Puppet to start work. I have encountered a problem since puppetd not works well like a daemon in HPUX, so I had to include it as a cron job with the following line:

####### Puppet
* * * * * /usr/local/bin/puppetd --no-daemonize -o >/dev/null 2>&1

All the puppet functions I've tried work great, distribution configuration files, change permissions and ownership, etc.

Now I am researching how to create a software depot from compiled code to be distributed across multiple servers that do not have the compiler installed.

Re: Does anyone run a Puppet Node on HP-UX

I've managed to create a depot with Ruby compiled for HPUX 11.23 ia64.

The PSF file used is as follows:

# PSF file for Ruby 1.8.7 20090826
#
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
#
vendor
tag SISTEMASUNIX
title "Sistemas Unix"
description ""
end
#
product
tag Ruby
title "Ruby 1.8.7 (2009-06-12 patchlevel 174) [ia64-hpux11.23]"
description ""
revision 1.8.7-174
#
architecture HPUX_11.23/64
machine_type *:*64
os_name HP-UX
os_release B.11.23
os_version ?
#
fileset
tag bin
title "Ruby binaries"
revision 1.8.7
file -u 022 -g sys -o root /usr/local/bin/ruby
file -u 022 -g sys -o root /usr/local/bin/ri
file -u 022 -g sys -o root /usr/local/bin/erb
file -u 022 -g sys -o root /usr/local/bin/irb
file -u 022 -g sys -o root /usr/local/bin/rdoc
file -u 022 -g sys -o root /usr/local/bin/testrb
end
#
fileset
tag library
title "Ruby Libraries"
revision 1.8.7
file -u 022 -g sys -o root /usr/local/lib/libruby-static.a
# or
directory /usr/local/lib/ruby/1.8
file_permissions -u 022 -g sys -o root
file *
end
#
end
#

Then I executed the following commands:

# swpackage -vv -s /root/psf/ruby.psf -d /root/psf/depot/
# swpackage -d /root/psf/Ruby-1.8.7_174-11.23-ia64.depot -x target_type=tape -s /root/psf/depot Ruby

Once installed on another server, Ruby works perfectly. Then I installed Facter and Puppet without trouble.