System Administration

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

 
SOLVED
Go to solution
Alzhy
Honored Contributor

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

For example -- on my rx6600 running HP-UX 11.31, 4 FC-HBAs hooked up to an HP EVA 8100.


# ioscan -k -m dsf /dev/rdisk/disk5634
Persistent DSF Legacy DSF(s)
========================================
/dev/rdisk/disk5634 /dev/rdsk/c14t0d4
/dev/rdsk/c18t0d4
/dev/rdsk/c12t0d4
/dev/rdsk/c16t0d4
/dev/rdsk/c34t0d4
/dev/rdsk/c32t0d4
/dev/rdsk/c28t0d4
/dev/rdsk/c30t0d4
/dev/rdsk/c48t0d4
/dev/rdsk/c52t0d4
/dev/rdsk/c44t0d4
/dev/rdsk/c46t0d4
/dev/rdsk/c64t0d4
/dev/rdsk/c66t0d4
/dev/rdsk/c62t0d4
/dev/rdsk/c60t0d4
# diskinfo /dev/rdisk/disk5634
SCSI describe of /dev/rdisk/disk5634:
vendor: HP
product id: HSV210
type: direct access
size: 524288000 Kbytes
bytes per sector: 512

It clearly shows my multipath works. SO I only need to use /dev/rdisk/disk5634 in LVM or VxVM or in any other storage usage. HP-UX 11.31's mass storage stack MPIO will take care of the load balancing and redundancy (ALUA in this case as this is an EVA)


Hakuna Matata.
Craig Johnson_1
Regular Advisor

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

Yes our multipathing works. We have two FC connections and I see two paths to each disk PLUS the agile address.

Using the agile address in LVM, that is what you see in /etc/lvmtab.

We HAVE to get this working. We cannot reboot boxes to see disk.
Alzhy
Honored Contributor
Solution

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

Then CHECK your syslog / dmesg whenever you experience these episodes.

If you're lucky - it may tell what your issues really are.

Next - check your SAN- check the switch logs for port errors or if the switch ports serving your server's HBAs show a pattern of losing the connection(s).

Hakuna Matata.
Alzhy
Honored Contributor

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

Can you show us a sample of one of your disks in the above syntax showing indeed you have HP-UX 11.31 multipathing in play?
Hakuna Matata.
Steven E. Protter
Exalted Contributor

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

Shalom,

rmsf -x

((11.31 only))

You should not need powerpath no matter what EMC says if the disk array is supported by HP-UX.

Making the OE current (September 2010) and installing the QPK is a very good idea.

Also make sure there are no srdf or clones inside the EMC sim frame holding the disks.

You might want to disable legacy paths as well.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Craig Johnson_1
Regular Advisor

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

OK, from dmesg:

class : lunpath, instance 3
Evpd inquiry page 83h/80h failed or the current page 83h/80h data do not match the previous known page 83h/80h data on LUN id 0x0 probed beneath the t
arget path (class = tgtpath, instance = 3) The lun path is (class = lunpath, instance 3).Run 'scsimgr replace_wwid' command to validate the change

class : lunpath, instance 3
An attempt to probe existing LUN id 0x0 failed with errno of 14.

class : lunpath, instance 11
Evpd inquiry page 83h/80h failed or the current page 83h/80h data do not match the previous known page 83h/80h data on LUN id 0x0 probed beneath the t
arget path (class = tgtpath, instance = 13) The lun path is (class = lunpath, instance 11).Run 'scsimgr replace_wwid' command to validate the change

class : lunpath, instance 11
An attempt to probe existing LUN id 0x0 failed with errno of 14.

class : lunpath, instance 12
Evpd inquiry page 83h/80h failed or the current page 83h/80h data do not match the previous known page 83h/80h data on LUN id 0x0 probed beneath the t
arget path (class = tgtpath, instance = 12) The lun path is (class = lunpath, instance 12).Run 'scsimgr replace_wwid' command to validate the change

class : lunpath, instance 12
An attempt to probe existing LUN id 0x0 failed with errno of 14.

class : lunpath, instance 4
Evpd inquiry page 83h/80h failed or the current page 83h/80h data do not match the previous known page 83h/80h data on LUN id 0x0 probed beneath the t
arget path (class = tgtpath, instance = 7) The lun path is (class = lunpath, instance 4).Run 'scsimgr replace_wwid' command to validate the change

class : lunpath, instance 4
An attempt to probe existing LUN id 0x0 failed with errno of 14.


We ran the "scsimgr wwid" command on the four then another "ioscan -fnNC disk" and voila, the disks were seen and claimed.

Another of our admins reports that this doesn't always work, but in this case it did.

$t!$-
Advisor

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

it happened because of changes in zoning. You need to revalidate WWID for instance number which is already assigned to your lun.

with below command you can find out which are path or instance are showing auth_failed status

#scsimgr lun_map

After finding all instance number you need to revalidate those lun with below command
scsimgr â f replace_wwid â C lunpath â I

it will replace WWID with current one and make same path visible again.

$t!$-
Advisor

Re: EMC SAN Disk "NO_HW" on 11.31 - Fixed by reboot?

replace command has not appear properly above ..pasting again

scsimgr -f replace_wwid -C lunpath -I