cancel
Showing results for 
Search instead for 
Did you mean: 

EMS Monitor is not running

 
hpux_sun
Occasional Advisor

EMS Monitor is not running

Hi All,

 

can you help me.

 

i have one HP-UX B.11.11 server and hardware monitoring is not working .

#ps -eaf | grep -i monitor
    root  7488  7333  0 05:42:17 pts/1     0:00 grep -i monitor

 

i have tried with the below , but no luck


# /etc/opt/resmon/lbin/monconfig
use K to kill

# /sbin/init.d/diagnostic stop

Use "kill -9" to terminate any stray OnlineDiag process if there are any.

# /sbin/init.d/diagnostic start

# /etc/opt/resmon/lbin/monconfig
use E to enable

 

#swlist -l bundle | grep -i online
  OnlineDiag            B.11.11.21.06  HPUX 11.11 Support Tools Bundle, December 2009

please help me how to start the monitor.


 

 

9 REPLIES
rariasn
Honored Contributor

Re: EMS Monitor is not running

Hi:

 

grep "monitor" is not the correct process.

 

ps -ef | grep -E "emsagent|diagmond"| grep -v grep


    root  3026     1  0  Nov 22  ?        21:07 /usr/sbin/stm/uut/bin/sys/diagmond
    root  5956     1  0  Nov 22  ?         2:34 /etc/opt/resmon/lbin/emsagent

 

rgs,

hpux_sun
Occasional Advisor

Re: EMS Monitor is not running

hi,

both process are running, please tell me what will be the prob..

 

# ps -eaf | grep -i emsa
    root  5672     1  0 04:04:16 ?         0:00 /etc/opt/resmon/lbin/emsagent
    root 11899 11895  0 09:25:56 pts/1     0:00 grep -i emsa
# ps -eaf | grep -i diagmond
    root 11907 11895  0 09:26:19 pts/1     0:00 grep -i diagmond
    root  5466     1  0 04:01:34 ?         0:00 /usr/sbin/stm/uut/bin/sys/diagmond

rariasn
Honored Contributor

Re: EMS Monitor is not running

Hi:

 

The send_test_event command is used to cause a monitor to generate one or more test events.

 

# /opt/resmon/bin/send_test_event -v disk_em

# tail /var/opt/resmon/log/event.log

 

man send_test_event

 

rgs,

 

 

Dennis Handly
Acclaimed Contributor

Re: EMS Monitor is not running

>both process are running, please tell me what will be the problem

 

Why do you think there is a problem?  What's not working?

hpux_sun
Occasional Advisor

Re: EMS Monitor is not running

#ps -eaf | grep -i disk_em is not working.

rariasn
Honored Contributor

Re: EMS Monitor is not running

Event monitoring service is enabled?

rgs
hpux_sun
Occasional Advisor

Re: EMS Monitor is not running

yes, it is enabled.

Re: EMS Monitor is not running

Hi

 

check wether cimserver is running as below.

 

cimprovider -ls

 

Please also check mailx  or sendmail is working for your server. 

 

send test mail & check the event.log also.

 

 

 

 

 

rariasn
Honored Contributor

Re: EMS Monitor is not running

Hi:

 

Verify with:

 

# ps -ef | grep -i stm

 

#/etc/opt/resmon/lbin/monconfig

 

============================================================================
===================       Event Monitoring Service       ===================
===================      Monitoring Request Manager      ===================
============================================================================

  EVENT MONITORING IS CURRENTLY ENABLED <<<<<<<<<<<<<<
  EMS Version : A.04.20.11.03
  STM Version : A.66.00

 

and:

 

 

# /etc/opt/resmon/lbin/moncheck

 

rgs,