HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

ENABLING SNMP ON HPUX 11.31

 
SOLVED
Go to solution

ENABLING SNMP ON HPUX 11.31

Good morning.

I am trying to config SNMP on our HP-UX 11.31 machines.

We'll monitor the systems with Spectrum Software.

I prepare the "/etc/SnmpAgent.d/snmpd.conf" file like this:

get-community-name: D#123--@30
set-community-name: D#123--@30
contact: Unidad de Servidores.
contact: MAPFRE - Venezuela
location: Casa Matriz - La Urbina # enter location of agent
#max-trap-dest: # enter max no. of trap-dest entries to be maintained.
trap-dest: 1.2.3.4
trap-dest: 5.6.7.8

What else do I have to change?.

Thank you!.
6 REPLIES
DaBe
Occasional Advisor

Re: ENABLING SNMP ON HPUX 11.31

Hi Mario,

just update the /etc/snmmp.conf (or the equivalent link to etc/SnmpAgent.d/snmpd.conf - you already did that) with your settings, enable Snmp-Daemon in the rc-file and start the SnmpMaster Agent.

# vi /etc/rc.config.d/SnmpMaster
SNMP_MASTER_START=1 # Start the master SNMP agent.
export SNMP_MASTER_START

# /sbin/init.d/SnmpMaster start

Good Luck!

Re: ENABLING SNMP ON HPUX 11.31

Thank you DaBe.

Those changes are already done... but the traps are not going any were.

I also check these files:

/etc/SnmpAgent.d/snmpd.conf
/etc/snmpd.conf
/usr/newconfig/etc/SnmpAgent.d/snmpd.conf


No success...

Any other idea?.

Thank you!.
DaBe
Occasional Advisor
Solution

Re: ENABLING SNMP ON HPUX 11.31

I think there is also some problem in your snmpd.conf File.
As # is used for comments, this might be one problem. Try without the # in your community string.
Did you configure the ip-adress of your spectrum server as trap-destination?

see changes below:

get-community-name: D123--@30
set-community-name: D123--@30
contact: Unidad de Servidores.
contact: MAPFRE - Venezuela
location: Casa Matriz - La Urbina # enter location of agent
#max-trap-dest: # enter max no. of trap-dest entries to be maintained.
trap-dest:

After doing the changes, don't forget to restart SnmpMaster

# /sbin/init.d/SnmpMaster stop && /sbin/init.d/SnmpMaster start

Good Luck !

Re: ENABLING SNMP ON HPUX 11.31

Hi DaBe.

You where completly right, as simple as that. The problem was the simbol "#".

Thank you again!.

Have a nice day!.

Re: ENABLING SNMP ON HPUX 11.31

Closed.
DaBe
Occasional Advisor

Re: ENABLING SNMP ON HPUX 11.31

If the answer has helped you, please don't forget to assign points.
Thank you.