System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Enable Quota limit across reboots.

 
Ramaprasad K
Regular Advisor

Enable Quota limit across reboots.

Hi,

Just few clarifications.

Quota (both hard and soft) limits has been established for users. But gets disabled after reboot. After going through man page for quota(5), found out that quota option needs to be entered against FS to enable quota across reboots. Is this true, I mean have I understood it right? Did anyone had to do this? And, should the entry be made manually (using vi on /etc/fstab) or any command with options?

Another clarification needed is whether 'time limit' needs to be mentioned to enable 'hard quota limit'? And can 'hard limit' be smaller than 'soft limit'? (though logically doesn't sound proper, got this doubt from question posted by 'peterchu' at http://forums11.itrc.hp.com/service/forums/questionanswer.do?admit=109447626+1231388023354+28353475&threadId=821490 .

Thanks,
Ram
3 REPLIES
sujit kumar singh
Honored Contributor

Re: Enable Quota limit across reboots.

basically for enabling quota on the filesystems across reboots u need to put in the /etc/fstab for that file system an entry in the mount option as "quota".

Along with the other mount options u need to put the entry quota in the options field of the /etc/fstab that is the 4 th column.


Typically, the Hard Limits should be larger than the soft limits that te quotas impose.


Regards


Sujit
Ramaprasad K
Regular Advisor

Re: Enable Quota limit across reboots.

Thanks Sujit for the response.
Ramaprasad K
Regular Advisor

Re: Enable Quota limit across reboots.

Suggested Sys admin to include 'quota' in the 'options' field in each line of filesystem entry in '/etc/fstab'.

Has been done but not tested yet as Server can't be rebooted for time being. Hope it works.

Thanks,
Ramaprasad K