System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Error While installing Mod_perl

JackNicolson
Occasional Visitor

Error While installing Mod_perl

Hi All,
I am installing mod_perl in my machine but getting some error below is the procedures which I followed for installing the mod_perl
Step1 : perl Makefile.PL MP_APR_CONFIG=/usr/local/apache2/bin/

asked for apache path given : /usr/local/apache2

Step2: make

Step 3: make test

In the above step I am getting error below is the part of error

/usr/bin/perl -Iblib/arch -Iblib/lib \
t/TEST -clean
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl /home/Documents/mod_perl-2.0.4/t/TEST -clean
APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT= APACHE_TEST_USER= APACHE_TEST_APXS= \
/usr/bin/perl -Iblib/arch -Iblib/lib \
t/TEST -bugreport -verbose=0
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl /home/Documents/mod_perl-2.0.4/t/TEST -bugreport -verbose=0
mod_perl 2 was built against Apache sources, we don't know where httpd/apxs executables are, therefore skipping the test suite execution at /home/Documents/mod_perl-2.0.4/Apache-Test/lib/Apache/TestConfig.pm line 382.
+--------------------------------------------------------+
| Please file a bug report: http://perl.apache.org/bugs/ |
+--------------------------------------------------------+
make: *** [run_tests] Error 2
linux/home/Documents/mod_perl-2.0.4 # perl Makefile.PL MP_APR_CONFIG=/usr/l


help me if I am doing anything wrong.


Thanks
Jack
4 REPLIES
James R. Ferguson
Acclaimed Contributor

Re: Error While installing Mod_perl

Hi Jack:

A bit more information, beginning with:

1. What operating system? HP-UX, Linux, what Linux distribution?

2. What operating system version?

3. What Perl version?

...would be nice to post.

Regards!

...JRF...



JackNicolson
Occasional Visitor

Re: Error While installing Mod_perl

Hi James,

My operating system version is suse linux 10 and perl is 5.5
James R. Ferguson
Acclaimed Contributor

Re: Error While installing Mod_perl

Hi (again) Jack:

Well, it's been awhile :-)

> My operating system version is suse linux 10 and perl is 5.5

There was no Perl 5.5. There was 5.005 and then 5.6.0, both of which are very old releases now.

If you aren't running at least 5.8.x I would begin by updating to that.

Regards!

...JRF...
JackNicolson
Occasional Visitor

Re: Error While installing Mod_perl

Hi James,

The main issue is that I want to create a request handler in my apache server so that I can handle the user content request stored in my apache server with respect to url is sending. and add extra content accordingly, I asked in some java forums for the same and I got that using CGI script we can do that. I thought using mod_perl I can create that handler.

Thanks