System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Error compiling apache 2.2.12

 
Fidel Ramirez_1
Frequent Advisor

Error compiling apache 2.2.12

I'm compiling Apachec source code version 2.2.12 this way:
./configure --enable-layout=TMaG --enable-ssl --enable-cache --enable-disk-cache --enable-mem-cache
But when running make, the following error occurs:
libtool: link: only absolute run-paths are allowed
make[3]: *** [libapr-1.la] Error 1
make[3]: Leaving directory `/data/install/httpd-2.2.12/srclib/apr'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/data/install/httpd-2.2.12/srclib/apr'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/data/install/httpd-2.2.12/srclib'
make: *** [all-recursive] Error 1

Can someone help me fix this error?
I'm trying to compile Apache with ssl.
Thank you for your help.
1 REPLY
Ragu_3
Trusted Contributor

Re: Error compiling apache 2.2.12

Pass the --libdir option to the autoconfigurator.

Example './configure --enable-layout=TMaG --enable-ssl --enable-cache --enable-disk-cache --enable-mem-cache --libdir=/data/install/httpd-2.2.12/srclib/apr'

Hth.
Debian GNU/Linux for the Enterprise! Ask HP ...