Error in running swinstall

 
Srimalik
Valued Contributor

Error in running swinstall

Hi

I am trying to install a package on DRD image but drd runcmd swinstall is failing giving out the following error
#################################

======= 01/08/09 18:29:12 IST BEGIN swinstall SESSION
(non-interactive) (jobid=habhpth9-0006) (drd session)

* Session started for user "root@habhpth9".

* Beginning Selection
* Target connection succeeded for "habhpth9:/".
ERROR: "habhpth9:/tmp": You do not have permission for this
operation. The depot owner, system administrator, or
alternate root owner may need to use the "swreg" or "swacl"
command to give you permission. Or, to manage applications
designed and packaged for nonprivileged mode, see the
"run_as_superuser" option in the "sd" man page.
* Source connection failed for "habhpth9:/tmp".
WARNING: More information may be found in the daemon logfile on this
target (default location is
habhpth9:/var/adm/sw/swagentd.log).
* Selection had errors.

######################

swagentd.log shows:

* Started list agent on "/tmp" for
root@Habhpth9, pid=4373, Thu, Jan 8, 2009
06:28:23 PM IST
* Agent pid=4373 completed. Thu, Jan 8, 2009 06:28:23 PM IST
* Started list agent on "/tmp" for
root@Habhpth9, pid=4376, Thu, Jan 8, 2009
06:28:45 PM IST
* Agent pid=4376 completed. Thu, Jan 8, 2009 06:28:45 PM IST
* Started list agent on "/tmp" for
root@Habhpth9, pid=4378, Thu, Jan 8, 2009
06:28:46 PM IST
* Agent pid=4378 completed. Thu, Jan 8, 2009 06:28:46 PM IST
ERROR: Cannot authenticate local principal "root".
ERROR: Access denied to start source agent on /tmp. No user
authenticated. Thu, Jan 8, 2009 06:29:13 PM IST

######################

When I install the package on the active system image it installs without any problems.

Any idea what is happening, Am I missing something obvious?

Thanks
Sri
abandon all hope, ye who enter here..
12 REPLIES 12
Ganesan R
Honored Contributor

Re: Error in running swinstall

Hi Srikrishan,

Can you register the depot and try to install?

#swreg -l depot
Best wishes,

Ganesh.
Srimalik
Valued Contributor

Re: Error in running swinstall

I have already tried that but it didn't help :-(.

-Sri
abandon all hope, ye who enter here..
Delcho Tuhchiev
Frequent Advisor

Re: Error in running swinstall

Hi,

I suggest to try to restart swagentd (/sbin/init.d/swagentd restart).
This works for me in some situations! Just try it!
Torsten.
Acclaimed Contributor

Re: Error in running swinstall

What software is it and what is your command line?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Srimalik
Valued Contributor

Re: Error in running swinstall

>This works for me in some situations! Just try it!

No, It didn't help. Actually in case of DRD installs a different(new) swagentd is started

>What software is it and what is your command line?

drd runcmd swinstall -s /tmp VRTSsfmh.

abandon all hope, ye who enter here..
Torsten.
Acclaimed Contributor

Re: Error in running swinstall

Is the /tmp directory really a registered depot or do you have another depot file?

Did you try to just list the contents?

swlist -s /tmp

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Srimalik
Valued Contributor

Re: Error in running swinstall

Yes, /tmp has the software and swlist @/tmp shows that the package is actually there.
abandon all hope, ye who enter here..
Srimalik
Valued Contributor

Re: Error in running swinstall

The first thing I am going to do tomorrow is to check whether any other software can be installed on an inactive image.
abandon all hope, ye who enter here..
Srimalik
Valued Contributor

Re: Error in running swinstall

Couldn't wait till morning

tried to install another software from a remote server and it succeeded.

Not sure what is the problem with this one. :-(
abandon all hope, ye who enter here..