System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Error when installing patch PHSS_33279 (11.23 u2comp/be/plugin library patch)

Waelkhalil_1
Frequent Advisor

Error when installing patch PHSS_33279 (11.23 u2comp/be/plugin library patch)

Hi all

i am trying to istall the following patches on HP-UX 11i v.23 June 2008,to upgrade oracle from 10.2.1.0 to 10.2.0.3

but the following 3 patches is needed to complete the oracle patch succefully :

C and C++ patches for PL/SQL native compilation, Pro*C/C++, Oracle Call Interface, Oracle
C++ Call Interface, Oracle XML Developer's Kit (XDK):
¡ PHSS_33277 11.23 HP C Compiler (A.06.02)
¡ PHSS_33278 11.23 aC++ Compiler (A.06.02)
¡ PHSS_33279 11.23 u2comp/be/plugin library patch


But the problem is when i try to install the patch PHSS_33279 (whic is the base one of the other 2 patches)...i got the following error (this is the log i got ):


======= 01/06/09 19:21:01 WAT BEGIN install AGENT SESSION (pid=8023)
(jobid=xxxxxxxx-0059)

* Agent session started for user "root@xxxxxxx". (pid=8023)

* Beginning Analysis Phase.
* Source:
xxxxxxxx:/usr/Software/Patches/PHSS_33279.depot
* Target: xxxxxxxx:/
* Target logfile: xxxxxxxx:/var/adm/sw/swagent.log
* Reading source for product information.
* Reading source for file information.
NOTE: The patch fileset "PHSS_33279.LANG-AUX,r=1.0" may only be
installed upon a previously installed base fileset. The
specification for this base fileset is
"Auxiliary-Opt.LANG-AUX,fr=B.11.23.06,v=HP". Since there is
no fileset on the target or selected from the source which
matches this specification, fileset
"PHSS_33279.LANG-AUX,r=1.0" will be excluded.
* Executing preDSA command.

* Summary of Analysis Phase:
* 1 of 1 filesets will be Skipped.
* The Analysis Phase succeeded.


* Beginning Analysis Phase.
NOTE: An alternate source host has not been configured. Using the
local host.
NOTE: An alternate source path has not been configured. Using
"/usr/Software/Patches/PHSS_33279.depot".
* Source:
xxxxxxxx:/usr/Software/Patches/PHSS_33279.depot
* Target: xxxxxxxx:/
* Target logfile: xxxxxxxx:/var/adm/sw/swagent.log
* Reading source for product information.
* Reading source for file information.
NOTE: The patch fileset "PHSS_33279.LANG-AUX,r=1.0" may only be
installed upon a previously installed base fileset. The
specification for this base fileset is
"Auxiliary-Opt.LANG-AUX,fr=B.11.23.06,v=HP". Since there is
no fileset on the target or selected from the source which
matches this specification, fileset
"PHSS_33279.LANG-AUX,r=1.0" will be excluded.
* Executing preDSA command.

* Summary of Analysis Phase:
* 1 of 1 filesets will be Skipped.
* The Analysis Phase succeeded.


3 REPLIES
Bob E Campbell
Honored Contributor

Re: Error when installing patch PHSS_33279 (11.23 u2comp/be/plugin library patch)

You can only install a patch if you have the product being patched. Run the command:

# swlist -l fileset Auxiliary-Opt

and you should find that the LANG-AUX fileset (if not entire product) is either missing or not at revision B.11.23.06.
Andres_13
Respected Contributor

Re: Error when installing patch PHSS_33279 (11.23 u2comp/be/plugin library patch)

Are HP C Compiler (A.06.02)and
aC++ Compiler (A.06.02)installed?

If not just follow with your Oracle installation because this wont be an issue.

Regards
Dennis Handly
Acclaimed Contributor

Re: Error when installing patch PHSS_33279 (11.23 u2comp/be/plugin library patch)

>i am trying to install the following patches

Why? You mentioned:
C and C++ patches for PL/SQL native compilation, Pro*C/C++, Oracle Call Interface, Oracle C++ Call Interface, Oracle XML Developer's Kit (XDK):

If you are not doing those, you don't need those patches. And if you don't have the aCC6 compiler, you can't patch it.
And A.06.02 is obsolete. The current version is A.06.22.