System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Error while starting apache web server

SOLVED
Go to solution
bchinnat
Frequent Advisor

Error while starting apache web server

Hi All,

In HP-UX 11.23, the HP-UX Apache-based Web server was installed by default while build the server. After that, we tried to start the process as below and getting the error as below. I dont have any knowledge about this apache pkg. I would like to know it is the error because of the liberary file or any thing related to the application(apache) I need to change......

#./apachectl start
/usr/lib/hpux64/dld.so: End of liblist, invalid RTLD_NEXT argument.


Thanks in Advance!!!!!!!!!!!
8 REPLIES
Dennis Handly
Acclaimed Contributor
Solution

Re: Error while starting apache web server

/usr/lib/hpux64/dld.so: End of liblist, invalid RTLD_NEXT argument.

What version of linker/dld patch do you have?
The latest is PHSS_39821.
bchinnat
Frequent Advisor

Re: Error while starting apache web server

Thanks for your reply on this..

But I could see the below linker patches in teh server:
bash-4.0# /usr/contrib/bin/show_patches |grep -i linker*
PHCO_31664 Japanese linker/compiler manpages
PHCO_33763 linker/compile English manpages
PHSS_34353 linker + fdp cumulative patch

So any suggestion here...
Rita C Workman
Honored Contributor

Re: Error while starting apache web server

Oh My!! That linker patch is from 2006 and about a dozen patch versions old.

Dennis has nailed it! You need to check your patches and get them upgraded. I have no doubt your java patches are too old as well.

Regards,
Rita
bchinnat
Frequent Advisor

Re: Error while starting apache web server

Hi,

So the patch upgrade will resolve this issue?..

Thanks,
Bala.
Johnson Punniyalingam
Honored Contributor

Re: Error while starting apache web server

Yes, Sir, Please proceed to patch upgrade for linker/dld
Problems are common to all, but attitude makes the difference
Dennis Handly
Acclaimed Contributor

Re: Error while starting apache web server

>So the patch upgrade will resolve this issue?

We are hoping it will. (Fingers crossed.)
bchinnat
Frequent Advisor

Re: Error while starting apache web server

Hi,

The patch Bundle is latest one in the server , So can I upgrade the linker by installing the patch
PHSS_39821 or if you could suggest some patch bundle then it would be great helpful.

Thanks...
bchinnat
Frequent Advisor

Re: Error while starting apache web server

Thanks for every one!!!!!!!!

The issue got resolved after the installation of the linker patch..