HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

Exrequisite dependencies.

 
SOLVED
Go to solution
r4mp4g3
Advisor

Exrequisite dependencies.

Hi, How can I check the exrequisite dependencies for a depot?

I'm trying to instlal the Guest Tools on a newly installed HP Virtual Machine 4.1 guest but it says the following:

* 1 fileset(s) have been excluded due to exrequisite
dependencies.


The fileset "vmTools.VMTOOLS-RUN,r=B.04.10" was excluded due
to an exrequisite dependency on "vmKernel"


Any way of knowing which installed product is conflicting with this?

Virtual Partitions (vPars) is not installed, by the way.
22 REPLIES
Torsten.
Acclaimed Contributor

Re: Exrequisite dependencies.

It's mentioned in the swagent log some lines above.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Michael Steele_2
Honored Contributor

Re: Exrequisite dependencies.

Hi

I have no idea what exrequisite dependicies are for a depot. Nor can I get a valid hit when searching.
Support Fatherhood - Stop Family Law
Torsten.
Acclaimed Contributor

Re: Exrequisite dependencies.

This may happen if you don't install the AVIO bundles for example. However, the reason will be in the logs.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
OldSchool
Honored Contributor
Solution

Re: Exrequisite dependencies.

according to:
http://docs.hp.com/en/5992-5875/ch10s04.html

"Exrerequisite
Software that may not be present when the fileset is operated on by SD-UX. For example, specifying an exrequisite for a fileset prevents the fileset from being installed if any of the specified exrequisite software objects are installed or are being installed."

Since the message is:

The fileset "vmTools.VMTOOLS-RUN,r=B.04.10" was excluded due
to an exrequisite dependency on "vmKernel"

I'd look for vmKernal in the logs. If appears to already be installed, and can't be if you want the VMTOOLS?
Torsten.
Acclaimed Contributor

Re: Exrequisite dependencies.

To make it a bit easier please tell if this is the host or guest and send a "swlist".

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Michael Steele_2
Honored Contributor

Re: Exrequisite dependencies.

software excluded messages appear during swinstall. So run a preview, swinstall -p
Support Fatherhood - Stop Family Law
Shinji Teragaito_1
Respected Contributor

Re: Exrequisite dependencies.

You are attempting to install HPVM Guest Kit on the HOST, not a
GUEST. You can know the conflict filesets by specifying
"-a exrequisites" as follows:

# swlist -a exrequisites -s /opt/hpvm/guest-images/hpux/11iv3/hpvm_guest_depot.11iv3.sd HPVM-Guest.vmTools

# HPVM-Guest
# HPVM-Guest.vmTools
HPVM-Guest.vmTools.VMTOOLS-MAN
HPVM-Guest.vmTools.VMTOOLS-RUN vmKernel T2767AC.HPVM T2767BC.HPVM

To install HPVM-Guest successfully, it's required
that "vmKernel", "T2767AC.HPVM" and "T2767BC.HPVM" are not
installed. NOTE: This is the result on HPVM 4.1.

Hope this helps
r4mp4g3
Advisor

Re: Exrequisite dependencies.

Thanks everyone! The solution was to remove the "VMKernel" product. I've dumped an Ignite recovery of a machine that's an VM Host itself on a VM Guest... so I had to remove the VM Host software.

By the way, I got another problem XD... I'm trying to move a volume group (its disks) from one server to another... but I cannot deactivate the VG cuz Im not able to umount a filesystem created on it.

This box is out Ignite server and I'm trying to umount the fs /var/opt/ignite/recovery/archives... performing an lsof or fuser shows nothing accesing this FS but when I try to umount it says its "busy". Anything to do without rebooting?

Thanks.
Torsten.
Acclaimed Contributor

Re: Exrequisite dependencies.

It's maybe an NFS export. Check this!

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
r4mp4g3
Advisor

Re: Exrequisite dependencies.

I've stopped the NFS services and the problem still exists.
Torsten.
Acclaimed Contributor

Re: Exrequisite dependencies.

See if it is listed in the exports file, comment and do the export again.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Michael Steele_2
Honored Contributor

Re: Exrequisite dependencies.

Hi

Re: "...but I cannot deactivate the VG cuz Im not able to umount a filesystem created on it..."

Run

fuser -cu /filesystem, to preview
fuser -cuk /filesystem, to kill left around processes

Note: Often, it your process. Your shell pid. Did you

cd /filesystem?
Support Fatherhood - Stop Family Law

Re: Exrequisite dependencies.

>Torsten: See if it is listed in the exports file, comment and do the export again.

That may not be good enough. You probably have to use "exportfs -u filesystem".
r4mp4g3
Advisor

Re: Exrequisite dependencies.

Hi, this box is a HP-UX 11.31... so I use /etc/dfs/dfstab instead of /etc/exports. I've tried to comment entries in dfstab and do a "shareall" again and I've done an "unshareall" so that nothing was exported but with no success so far... the FS remains busy!
r4mp4g3
Advisor

Re: Exrequisite dependencies.

By the way, the "fuser -ck /FS" and so was the first thing I did... but as I commented before nor in fuser neither in lsof output It shows nothing... There is no user with that FS as current directory.
Shinji Teragaito_1
Respected Contributor

Re: Exrequisite dependencies.

Did you try to specify the force option (-f) to umount on your 11.31 environment ?
Michael Steele_2
Honored Contributor

Re: Exrequisite dependencies.

Hi

a) Check for duplicate minor numbers with group files

b) vgdisplay -v vg
Compare current and open LVs

c) If you are running BCV's, verify the sync has completed

Question: Is this a BCV vg?
Support Fatherhood - Stop Family Law
r4mp4g3
Advisor

Re: Exrequisite dependencies.

Hi again,

1) The force option (-f) does not exist in HP-UX.

2) This is not a BCV VG.
Michael Steele_2
Honored Contributor

Re: Exrequisite dependencies.

Its vgreduce -f vg

/usr/sbin/vgreduce [-A autobackup] [-f] vg_name

http://docs.hp.com/en/B2355-91020/B2355-91020.pdf
Support Fatherhood - Stop Family Law
r4mp4g3
Advisor

Re: Exrequisite dependencies.

?

I meant the umount command doesnt have an "-f" option. Why would I want to perfom a vgreduce?
r4mp4g3
Advisor

Re: Exrequisite dependencies.

Anyone has any idea???
Michael Leu
Honored Contributor

Re: Exrequisite dependencies.

Hi r4mp4g3

I've had this problem multiple times on a PA-RISC 11.31 system with the /var/opt/ignite mountpoint. lsof and fuser where always empty. Killed practically all processes on the system, still not umountable. Had to reboot the system :-(