cancel
Showing results for 
Search instead for 
Did you mean: 

Re: FCP driver not loaded.

 
SOLVED
Go to solution
HDgio
Regular Advisor

FCP driver not loaded.

I've an A3740 Fibre-channel installed on a L2000 whith a driver A5158A connect on a FC60.
I can't see a LUN configured on FC60
with the command fcmsutil /dev/fcms10 the output is:
Error: FCP driver not loaded.
Can help me ?
Bye
8 REPLIES 8
LucianoCarvalho
Respected Contributor
Solution

Re: FCP driver not loaded.

Hi,

Try to install the last patch fors
11.00 or 11.11 Fibre Channel Mass Storage Driver Patch

regards
Steven E. Protter
Exalted Contributor

Re: FCP driver not loaded.

You need to go to your Core OS, Application CD or software.hp.com and download and install the driver for that card.

Then use swinstall to install it. It will boot your system.

Unless you already did so and the hardware has failed. Let me know.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ashwani Kashyap
Honored Contributor

Re: FCP driver not loaded.

the A3740 and A5158A are different Tachyon Cards .

The device files for A5158A are /dev/td* while A3740 are /dev/fcms* .

I am not sure whether A5158 driver will work on A3740 .

I think you need to install the Fibre Channel Mass storage driver patch for 11.X and if not already included , include all the fibre channel drivers like fcp , td, tcms ,fct1_cntl , fcT1_fcp in the kernel via sam or any other method .
HDgio
Regular Advisor

Re: FCP driver not loaded.

In a server I've two card A3740 whith a patch installed the output of the fcmsutil command of two devices is:
fcmsutil /dev/fcms11
Error: FCP driver not loaded.

Local N_Port_ID is = 0x000001 N_Port Node World Wide Name= 00000108333AF1A
N_Port Port World Wide Name=x100000108333AF1A
Topology = IN_LOOP
Speed = 1062500000 (bps)
HPA of card = 0xF9EFF000
EIM of card = 0xFFFFFFFF
Driver state = OFFLINE
Number of EDB's in use = 0
Number of OIB's in use = 1
Number of Active Outbound Exchanges = 1
Number of Active Login Sessions = 3

fcmsutil /dev/fcms10
Error: FCP driver not loaded.

Local N_Port_ID is = 0x000000
N_Port Node World WideName=0x100000108333CFE9
N_Port Port World WideName=0x100000108333CFE9
Topology = UNKNOWN
Speed = 1062500000 (bps)
HPA of card = 0xF96FF000
EIM of card = 0xFFFFFFFF
Driver state = DEAD
Number of EDB's in use = 0
Number of OIB's in use = 1
Number of Active Outbound Exchanges = 0
Number of Active Login Sessions = 0
Ashwani Kashyap
Honored Contributor

Re: FCP driver not loaded.

From the man pages of fcmsutil :
UNKNOWN=The host bus adapter is not attached to a loop/loopback hood or has connection problems and could not come up in a valid topology.

IN_LOOP/PRIVATE_LOOP=The host bus adapter is attached to a loop/loopback hood.

DEAD=The driver couldn't come up due to some problem. Check the connectivity with the loop/loopback hood.

OFFLINE. The host bus adapter is not participating on the loop.


So I would check the connectivity of theHBA's .
Also do a more on /stand/ssystem and see if the driver fcp is in there . If not include it in the kernel , recompile the kernel and reboot .
HDgio
Regular Advisor

Re: FCP driver not loaded.

In a two Server I've found two different card
of fibre-channell.
In a server A there is two A3740
In a server B ther is two A5158
You no if there is an incompatible
The card is connected at two different Fibre-hub
Ashwani Kashyap
Honored Contributor

Re: FCP driver not loaded.

what OS version are you on .
It apperas that A3740 is not supported on HPUX 11.11 and higher .
HDgio
Regular Advisor

Re: FCP driver not loaded.

HP-UX 11.00