HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

FTP permission

 
unixguy_1
Regular Advisor

FTP permission

User is created any file, the file permission should be "rw-rw-r--"
User transfer any file through FTP, it could be changed to "rw-r-----"

user account uamsk value is 002,
now user required permision is "rw-r--r--"

please help ,how to resolve this issue.

4 REPLIES
TwoProc
Honored Contributor

Re: FTP permission

umask is not used for ftp, because your shell is not used for ftp. Your .profile is not read, not processed, and of no use to ftp.

However, when whoever or whatever ftps the file, they can run the chmod command on the file after it finishes being put on the destination server.
We are the people our parents warned us about --Jimmy Buffett
James R. Ferguson
Acclaimed Contributor

Re: FTP permission

Hi:

You can control the file mode by adding a umask value to the 'ftpd' daemon as spawned by 'inetd' in '/etc/inetd.conf' ('-u umask') and by using the 'ftpaccess' file (and adding '-a' to the 'ftp' specification in 'inetd.conf').

See the manpages for 'ftpd', 'ftpacess' and 'inetd' for more information.

Regards!

...JRF...
bullz
Super Advisor

Re: FTP permission

U can use sftp, insted of ftp i guess.
There is a option of umask in sftp.

For more information man sftp
singh sanjeev
Trusted Contributor

Re: FTP permission

Yes , in SFTP you can use umask option for the file permission.

please check your sshd.config file.
Sanjeev Singh