System Administration
Showing results for 
Search instead for 
Do you mean 

Force NFS to version 2 on 11.23 IA64

Occasional Contributor

Force NFS to version 2 on 11.23 IA64

I have a 11.23 server that I am trying to mount NFS volumes on. How can I force this machine to only use NFS version 2?

The server is a Solaris machine with ZFS and there is a bug that only affects 11.23. The solution provided by Sun is to use NFSv2 or upgrade to 11.31. I cannot upgrade the machine so my only option is to use NFSv2. Other machines are accessing the NFS volume so I cannot change the NFS server to use version 2.

When I mount the volumes they are mounting as version 3. I added the vers=2 option but that seems to be ignored.

I've tried mounting the volumes using automount, fstab and manually but the result is always the same.

Thanks
6 REPLIES
Esteemed Contributor [Founder]

Re: Force NFS to version 2 on 11.23 IA64

Hi jessie,

Here is a suggestion. Turn the VERSMIN and VERSMAX parameters to 2 in /etc/default/nfs . See if it takes only NFS v2 after the appropriate services are started and stopped.

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....
Occasional Contributor

Re: Force NFS to version 2 on 11.23 IA64

Nope that didn't seem to do anything. The file /etc/default/nfs did not exist so I created it.
Advisor

Re: Force NFS to version 2 on 11.23 IA64

Jessie,

What version of solaris are you using? I assume 10.
The file /etc/default/nfs should be on the solaris machine already.

And by default has the following, so default settings should work:

# Sets the minimum version of the NFS protocol that will be registered
# and offered by the server. The default is 2.
#NFS_SERVER_VERSMIN=2

Just for the sake of it.
Did you also do the following on the Solaris box?

# svcadm restart nfs/server


Also try doing showmount -e from the HP-UX server to see if you can see the shares.

Hope it helps,

Manuel
HPE Pro

Re: Force NFS to version 2 on 11.23 IA64

What is the exact syntax you're using on the 11i v2 client to mount the filesystem. The "vers=2" option should not be ignored by the server so I'm wondering if you're using the correct syntax.

Dave
Occasional Contributor

Re: Force NFS to version 2 on 11.23 IA64

I am trying to get it to work with just mount to keep it simple.

mount -F nfs -o vers=2 server:/vol /sever/vol

After it mounts, the mount command shows defaults,dev=7600000a as the options.

The server is Solaris 10 with ZFS as the volume type and I cannot change that since it is sharing many volumes to many clients.
HPE Pro

Re: Force NFS to version 2 on 11.23 IA64

What does "nfsstat -m" show when run on the 11i v2 NFS client?

Dave