cancel
Showing results for 
Search instead for 
Did you mean: 

Frecover issue

mehul_3
Regular Advisor

Frecover issue

I have taken cold oracle database backup using fbackup command using /dev/rmt/2m volume on rx6600 and now I want to restore it on rx3600 using frecover command using /dev/rmt/1m(Software state is CLAIMED by giving ioscan -fnC tape command) volume with same Ultrium SCSI tape which I used on rx3600.But it gives us following error

$ frecover -v -f /dev/rmt/1m -r -o
frecover(5420): not an fbackup volume; magic value is incorrect
frecover(5412): Do you wish to try to salvage this volume? (^[yY]/^[nN]) n
frecover(5411): Do you wish to try a different volume? (^[yY]/^[nN]) n
frecover(5414): abort selected

Waiting for urgent reply.

Regards,
Mehul


5 REPLIES
OldSchool
Honored Contributor

Re: Frecover issue

if "frecover -r -v -o -y -f /dev/rmt/1m" doesn't work, then my fist inclination would be that the tape was not properly written to begin with.

without the actual command used to create the tape, and any messages that it produced, this can't be confirmed.

It read the drive you told it to, so the ioscan / claimed status is not relevant. the part that is: "not an fbackup volume".

It doesn't recognize what it found on the tape. you may have to run the cold backup again to get the data there.
Bill Hassell
Honored Contributor

Re: Frecover issue

Verify the backup on the original server (if possible) with the command:

frecover -V - -f /dev/rmt/2m

This will print the header (date/time, other fbackup details). If the command reports that this is not an fbackup volume, something has overwritten the front of your tape. If this works OK on the original system, use the same command on your rx3600 using the 1m tape drive ID. If that fails, do the two systems have the same Ultrium tape drive (there are several and they are not backwards compatible). There are Ultrium models: 200-series, 400-series, 900-series and the newest 1800-series. Each series corresponds to the industry standard LTO-1, LTO-2, LTO-3 and LTO-4 respectively. Each model series is a different density, although the lower capacity unit should reject a higher capacity tape.

Check your tape immediately after taking the backup using the above frecover command. To see a list of all the files, use:

frecover -I - /dev/rmt/1m


Bill Hassell, sysadmin
mehul_3
Regular Advisor

Re: Frecover issue

Hi bill
As you said, should I verify backup using mentioned command but the size of backup is 260 GB and I presume it will take too much time to be verified(Is it total time of backup taken?). Moreover, I am using same Ultruim 900 seris on both of the servers.
Waiting for reply

Reply
Mehul
Bill Hassell
Honored Contributor

Re: Frecover issue

> As you said, should I verify backup using mentioned command but the size of backup is 260 GB and I presume it will take too much time to be verified(Is it total time of backup taken?). Moreover, I am using same Ultruim 900 seris on both of the servers.

The man page is very helpful here. The -V option is used to read the first records on the tape -- it takes a couple of seconds. You can also use the -I option in the same way to list all the files that were selected for backup. Both -V and -I require an output file, so use - (dash) to put the information on your screen. The -V option is just a few lines and verifies that the tape is readable and compatible with frecover. The -I option shows the names of all the files.

And unlike cpio or tar, the fbackup format does not have to read the entire tape to get this information. You could verify the entire tape with frecover -N which will read everything, but that is not necessary based on your original question. Your question was about the error which states that the tape is not an fbackup tape. Note that one simple command like tar or cpio can overwrite the beginning of the tape, thus destroying the rest of the tape's contents. Unlike old reel-to-reel tape drives, once you write anything at the beginning of the Ultrium tape, nothing after that write is readable again.


Bill Hassell, sysadmin
mehul_3
Regular Advisor

Re: Frecover issue

Problem is due to following reason.

fbackup from highr version say 11.31 is not restored to any lower version say 11.11, 11.21 using frecover. One should have same version(11.31) on both of the server.

Regards,
Mehul