System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Getting error message "rlogind: Unable to allocate pty on remote host."

 
SOLVED
Go to solution
senthil_kumar_1
Super Advisor

Getting error message "rlogind: Unable to allocate pty on remote host."

Hi All,

I have K580 server running HP-UX 10.20.

I used to login through rlogin. It was working fine.

But suddenly, Today I am not able to connect the server through rlogin.

I am getting below given error message while try to connet through rlogin.

Example:


#rlogin serverA

rlogind: Unable to allocate pty on remote host.
Connection closed.


My Questions:

1)Why I am not able to connect the server through rlogin?

2)Will it be resolved if I go for reboot of the server?

3)How to resolve the issue?

It is very urgent.
7 REPLIES
Pete Randall
Outstanding Contributor
Solution

Re: Getting error message "rlogind: Unable to allocate pty on remote host."

All the pty's on your remote host are in use. You need to allocate more by increasing the value of npty in your kernel. Of course this requires building a new kernel and re-booting. If this can't be done immediately then you might be able to kill of some of the processes occupying pty's on the remote server.
A reboot of the server would also free up the pty's but I would suggest increasing the kernel parameter "npty" before re-booting.


Pete

Pete
Pete Randall
Outstanding Contributor

Re: Getting error message "rlogind: Unable to allocate pty on remote host."

Sorry for the repeated posting, but I should have mentioned that you can use glance on the remote server to see how many pty's are in use:

gpm > reports > system info > system tables report


Pete

Pete
senthil_kumar_1
Super Advisor

Re: Getting error message "rlogind: Unable to allocate pty on remote host."

Hi All,

My current setting:


Name Current Pending
Value Value
npty 200 200
nstrpty 200 200


What is the maximum value we can set. There is 4GB of RAM installed.
Pete Randall
Outstanding Contributor

Re: Getting error message "rlogind: Unable to allocate pty on remote host."

The maximum value is limited only be the memory available. However, keep in mind that raising the value only increases the size of the kernel minimally - like a few Kb at most. If I were you, I would at least double the current value.


Pete

Pete
Steven E. Protter
Exalted Contributor

Re: Getting error message "rlogind: Unable to allocate pty on remote host."

Shalom,

After Pete's steps it is necessary to run the following command.

insf -e

This will create terminal files and psuedo files needed for sessions.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
senthil_kumar_1
Super Advisor

Re: Getting error message "rlogind: Unable to allocate pty on remote host."

Hi All,

Therefore we have to follow below steps:

1)Increase the kernel parameter "npty"

2)Run #insf -e

3)reboot the server.
Dennis Handly
Acclaimed Contributor

Re: Getting error message "rlogind: Unable to allocate pty on remote host."