HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HBA_GetFcpTargetMapping feature not working

 
SOLVED
Go to solution
ITS Unix
Occasional Contributor

HBA_GetFcpTargetMapping feature not working

Hi,

Am trying to get the hbaping feature of heartbeat (linux-ha) to work.
(http://www.linux-ha.org/ha.cf/HbapingDirective)
Compiled the source and all seems to work except the HBA_GetFcpTargetMapping feature?
Any ideas how to fix this?

HP ProLiant DL380 G5, Heartbeat 2.1.2, RHEL AS 4.6

DL360
The hba driver and revision are listed below:

/var/tmp/hbaapi_src_2.2/hbaapitest
HBA API Library version is 2
Number of HBA's is 1

********************************************
Adapter number 0 is named: qlogic-qla2xxx-0
Adapter Attributes
Manufacturer:QLogic Corporation:
SerialNumber:MY50730FK9:
Model:HPAE311A:
ModelDesc:QLogic HPAE311A:
NodeWWN:0x500110A000172583
NodeSymName:HPAE311A HBA Driver:
HardwareVersion:PX2510401-11 E:
DriverVersion:v.8.01.07.25:
OptionROMVersion:v.1.09:
FirmwareVersion:v. 4.00.90:
VendorSpecificID:0:
NumberOfPorts:1:
DriverName:qla2xxx:

NumberofDiscoveredPorts:0
failure of HBA_GetFcpTargetMapping, status=1 <=== note the error!


3 REPLIES
Venilton Junior
Valued Contributor
Solution

Re: HBA_GetFcpTargetMapping feature not working

Have u tried the module that comes with PSP7.91?
RTFM
ITS Unix
Occasional Contributor

Re: HBA_GetFcpTargetMapping feature not working

the 8.01.06.01 version of the hba driver in psp7.91 worked! tnx a million!

Pitty this the 8.01.07.25 one didn't. Got it from hp as well: Linux Driver Kit for Qlogic HBAs (can paste the link here)

that doesn't bode well for the future.
Hope they fix that before it goes into the next psp.
ITS Unix
Occasional Contributor

Re: HBA_GetFcpTargetMapping feature not working

see my comment above