HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 9000 rp3440 hp 11

 
SOLVED
Go to solution
Phillip Popp
Regular Advisor

HP 9000 rp3440 hp 11

Hi,
I have a remote box rp3440 running hp11. I use vnc server to access a CDE gui as that box does not have a graphic interface for a monitor. My problem is that I can not launch a terminal window other then the one already launched. I am tryinh to launch from terminal icons, not sure of how to run a terminal window from the command line. When I try to run sam, I get the following error.


The display environment variable is set to "hpserv03:1.0", but the current configuration wont allow sam to run on that display.

The DISPLAY environment variable must be incorrect or if you are running sam remotely you may need to allow the remote system to access your local X server by typing
/usr/bin/X11/ xhost +hpserv03

on your local machine

I say no to running sam in a terminal version and try the command suggested above and get the error.

/usr/bin/X11/ xhost: unable to open display "hpserv03:1.0"

I am not very familiar with display settings or how t ochange the enviroment variable or what to set it to.

Any help you guys can give me would be great. As I mentioned it is not just sam but I can not launch any terminal window.

Thanks,

Phil
7 REPLIES
Sunny123_1
Esteemed Contributor
Solution

Re: HP 9000 rp3440 hp 11

Hi

Firstly export the display by doing following

#export DISPLAY=hpserv03:1.0:0.0

then run the command.


Regards
Sunny
Phillip Popp
Regular Advisor

Re: HP 9000 rp3440 hp 11

Thanks, but same result.
Phillip Popp
Regular Advisor

Re: HP 9000 rp3440 hp 11

Anyone else have any suggestions on this probelm?

Thanks

Phil
Steven E. Protter
Exalted Contributor

Re: HP 9000 rp3440 hp 11

Shalom Phil,

Suggestions:

If you have a Linux box or virtual machine available, try this.

ssh -X hpserv03

Then try xclock and check functionality.

The ssh command with the -X switch sets up an X windows tunnel, secure through ssh. It will let you run most X windows applications without difficulty.

You may still need to set your DISPLAY variable, depending on your profile settings, but you can set up as many connections as you desire this way.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Phillip Popp
Regular Advisor

Re: HP 9000 rp3440 hp 11

Thanks,
I do not have any other boxs. This worked before, I never haqd issues opening a terminal window.

Thanks,

phil
AnthonySN
Respected Contributor

Re: HP 9000 rp3440 hp 11

try
export DISPLAY=pc ip:0.0

eg
export DISPLAY=192.168.1.10:0.0
Viktor Balogh
Honored Contributor

Re: HP 9000 rp3440 hp 11

Hi Phil,

>I do not have any other boxs. This worked before, I never haqd issues opening a terminal window.

What did you change on the system? Maybe this could give you a clue where the problem lies...
****
Unix operates with beer.