System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HP UX 11.23 ERROR after installing curl 7.34

 
SOLVED
Go to solution
FRSTN83
Occasional Contributor

HP UX 11.23 ERROR after installing curl 7.34

Hello,

 

After installing curl 7.34 on HP UX 11.23 using swinstall with no errors or warnings, I've got the following error when trying to run curl -V:

 

./usr/local/bin/curl -V
/usr/lib/hpux32/dld.so: Unable to find library 'libsasl2.sl.3'.
Killed

 

Any idea Please?

 

Thank you.

4 REPLIES
FRSTN83
Occasional Contributor

Re: HP UX 11.23 ERROR after installing curl 7.34

I have reinstalled manually this time and I've another one:

/usr/local/bin/curl -v -4 https://10.44.6.53/hes/api/v0/commands
* Hostname was NOT found in DNS cache
* Trying 10.44.6.53...
* Adding handle: conn: 0x4006cee0
* Adding handle: send: 0
* Adding handle: recv: 0
* Curl_addHandleToPipeline: length: 1
* - Conn 0 (0x4006cee0) send_pipe: 1, recv_pipe: 0
* Connected to 10.44.6.53 (10.44.6.53) port 443 (#0)
* SSLv3, TLS handshake, Client hello (1):
* Unknown SSL protocol error in connection to 10.44.6.53:443
* Closing connection 0
curl: (35) Unknown SSL protocol error in connection to 10.44.6.53:443
/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'ERR_remove_thread_state' in load module '/usr/local/lib/hpux32/libcurl.so'.
Killed

 

Any Idea please?

Need your Help.

 

Thank you.

Steven Schweda
Honored Contributor

Re: HP UX 11.23 ERROR after installing curl 7.34

> After installing curl 7.34 on HP UX 11.23 using swinstall [...]

   And you got this depot where, exactly?

> I have reinstalled manually [...]

   What, exactly, did you install, how, exactly?

   I haven't installed "curl" on an HP-UX system lately, so I know
nothing, but if I were getting errors related to SSL, then I'd
investigate which OpenSSL version I had installed, and which OpenSSL
version my "curl" program was expecting.  Many OpenSSL versions exist,
and they are not all API-compatible.

   If you're starting from the "HP-UX Porting and Archive Centre", then
you might wish to try that "depothelper" to get all the prerequisites.
Otherwise, you might do better building "curl" from a source kit, so
that it finds the OpenSSL version which you have installed on your
system (assuming that it's compatible).

Steven Schweda
Honored Contributor
Solution

Re: HP UX 11.23 ERROR after installing curl 7.34

> Re: HP UX 11.23 ERROR [...]

   First, it's a "curl" error, not an HP-UX error.

   Second, a quick Web search for ERR_remove_thread_state found:

      https://www.openssl.org/docs/man1.1.0/crypto/ERR_remove_state.html

Which suggests that ERR_remove_thread_state first appeared in OpenSSL
1.0.0, so if you're still trying to use some version like 0.9.8, then
that could explain why dld.so can't find it.  (And it's been deprecated
since 1.1.0.)

   The dependencies listed at:
      http://hpux.connect.org.uk/hppd/hpux/Networking/WWW/curl-7.34.0/
seem to include OpenSSL 1.0.2k, which would be consistent with
ERR_remove_thread_state being used.

FRSTN83
Occasional Contributor

Re: HP UX 11.23 ERROR after installing curl 7.34

Thank you.

Installing OpenSSL 1.0.2 solved my problem.