HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX 11.31 Invalid Login Delay (couple seconds)

 
Mauro Livi
Valued Contributor

HP-UX 11.31 Invalid Login Delay (couple seconds)

Hi all,

Although it's not a huge issue, I find this rather strange.

 

We have a newly configured rx2800 i4 running HP-UX 11.31. When logging in successfully, response is pretty much immediate. However typing in incorrect credentials usually results in a delay of about 2-3 seconds for the server to display "Login incorrect".

 

I have a local PA-RISC server running 11.11 here (ie in the same building that I am) and unsuccessful login response is immediate.

 

The 11.31 server is approximately 300 miles away from here (ie from my building), but the fact that successful login response is immediate while unsuccessful login is not, kind of tells me it's not a network latency issue. So my question is what is it about unsuccessful logins that takes a few seconds to respond? Is it something at 11.31 that does something differently than 11.11?

 

I looked at the usual /etc/resolv.conf and /etc/nsswitch.conf files and nothing looks out of the ordinary...so I thought I'd fish for ideas.

 

Any input/suggestions/ideas would be greatly appreciated.

 

Thanks in advance

 

Mauro

11 REPLIES
Patrick Wallek
Honored Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

There is a setting in HP-UX called "Delay Between Login Tries (sec.):" and by default it is set to "2" seconds.

 

If you go into SAM/SMH, then to the "Auditing and Security" section, then to "System Security Policies", then to "Terminal Security {olicies" you will find that setting.

Mauro Livi
Valued Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

Thanks for your input Patrick.

 

Unfortunately when I go into SMH (I tried the GUI and "standard" versions) I don't see the options you are talking about. I've attached a screen shot of the SMH options displayed.

 

Strange thing is that if I go in my 11.11 SAM, I do see those options, but not at 11.31 SMH. Obviously something has changed between the two versions.

 

Furthermore, I'm guessing that the settings you are talking about are entries to the /etc/default/security file. So I'm still puzzled as to how to set this. Any ideas?

 

Thanks again

 

Mauro

Patrick Wallek
Honored Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

Before running SAM, try doing

 

# unset DISPLAY

 

so that it will just come up in your terminal.

 

 

I don't think the login delay is set in the security file as I can't find anything in the security man page for that.

Mauro Livi
Valued Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

Patrick, you mentioned SAM...I am using SMH on my 11.31 (I'm sure that was  a typo)

 

In any event, I saw no difference and I can verify that the DISPLAY variable is no set since when I launch SMH in text mode I get the message that reads "Display variable not set..."

 

I guess I'm missing the point  of your last post. Sorry :(

 

Anyway I do greatly appreciate the help

 

Mauro

Patrick Wallek
Honored Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

Yes, I did mention SAM.  And I do mean go into 'sam' and NOT smh.

 

If you have a display set then sam will try to start SMH in a browser running from the server.  If you do not have a display set then SAM should just come up in character mode.

 

 

Mauro Livi
Valued Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

Patrick,

 

That doesn't seem to be the case. If I type sam on this box I see the message flash that "System Administration Manager (SAM) is deprecated in this release of HP-UX...." then it goes into text based SMH.

 

So clearly SAM is not available at this version of 11.31

 

Thanks

 

Mauro

Patrick Wallek
Honored Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

So, once you got into the text based SMH (or SAM..whatever) did you try following my instructions?

 

That should get you to where you need to be.

Mauro Livi
Valued Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

 

 

Well that's just it...once I get in there (to Auditing and Security) how in the world do I navigate through it? What I see is shown below

 

When I get in there Audited Events is highlighted and I can't move the highlight off that. I've tried TAB, arrows, space, etc. Entering <CR> just goes into the highlighted item (Audited Events) and Esc gets me to the prior screen. Also there are no commands or indication on how to navigate (like the prior screen)...so I'm puzzled.

 

Why in the world would they not put this the GUI!!!!

 

Thanks

Mauro

 

 

                             Auditing and Security
--------------------------------------------------------------------------------
 Audited Events
 Audited System Calls
 Audited Users
 System Security Policies
 Authenticated Commands

 

 

 

 

 

 

 

-------------------------------------------------------------------------------

Patrick Wallek
Honored Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

When I get to that point my arrow keys and everything still work as they usually do.

 

I do know why they would fail. 

 

I also don't know why that is hard to find in the SMH gui, but then again I've never been a big fan of SMH as it makes me want to smh (smack my head).

Mauro Livi
Valued Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

Patrick,

 

It was with my terminal emulation software. I used putty, and that worked fine.

 

However, looks like in order to go into that option, you need to convert to a trusted system. I guess I can do that, but would like to check out the implications of doing it first.

 

Thanks again for your help.

 

Mauro

chindi
Respected Contributor

Re: HP-UX 11.31 Invalid Login Delay (couple seconds)

All users password will be deactivated within time-frame of 30 sec i guess ( Not sure about time , re-check it ) after converting to Trusted mode .

Just to avoid it , run /usr/lbin/modprpw -V immediately after you convert your system to trusted mode .

Then you can go ahead with Patrick's suggestions.