System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX 11i V2 automount and NFS version

 
Occasional Contributor

HP-UX 11i V2 automount and NFS version

Hi

We have a HP-UX 11i V2 (11.23) server running the automounter. We are using YP in our environment. Automounter is getting the maps via YP.

The auto_home is an indirect map provided via YP.
The mounts and the logins are happening good.
One thing we observed on this server is the home dirs are getting mounted using NFS v2( from the nfsstat -m output). This is causing the developers not to create the files >2GB.

But when I mount the home dir manually it is mounting with NFS V3. and the with NFS V3 there is no issue with the >2GB file creation (I can see the same from other posts).

How can I force the automounter to use NFS V3 or higher while mounting the homedirs via NFS?


5 REPLIES 5
Exalted Contributor

Re: HP-UX 11i V2 automount and NFS version

Shalom,

Update NFS on both ends of the connection. It is patch time.

NFS where possible will mount with the highest version of NFS possible.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Occasional Contributor

Re: HP-UX 11i V2 automount and NFS version

@SEP thanks for the reply.

I think I have the NFS versions required.

the same export is getting mounted via NFS V3 if I do a manual mount. But it is getting mounted via V2 through automounter. How do I force automounter to pick v3 instead of V2?
Honored Contributor

Re: HP-UX 11i V2 automount and NFS version

If you really have Automounter, according to the docs it seems that Automounter doesn't support NFSv3, only AutoFS does:

"Additionally, AutoFS uses the same maps as Automounter, and AutoFS supports the NFS PV3 protocol whereas the Automounter does not."

http://docs.hp.com/en/5992-2854/ch05s03.html

****
Unix operates with beer.
Honored Contributor

Re: HP-UX 11i V2 automount and NFS version

I am pretty sure that you have the Enhanced AutoFS installed. Check this way:

# swlist ENHAUTO

Maybe you could install the latest before any debugging:

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=ENHAUTO
****
Unix operates with beer.
Occasional Contributor

Re: HP-UX 11i V2 automount and NFS version

@Victor - Thank You.

Yeah in fact it was AutoFS. But the ENHAUTO is not isntalled.
the one on the HP swdepot website is for the 11.11 only.
We are running the 11.23. I am still searching for the compatible version for this.