HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX 11i v3 - 11.31 NFS Mount Issue. RPC: Program not registered

 
nij
Senior Member

HP-UX 11i v3 - 11.31 NFS Mount Issue. RPC: Program not registered

Hi,

 

I am facing issue while mounting NFS volume on NFS-Client-Server

 

NFS-Server

root@serv1 [/]# share
-               /dump   rw   "Dump Folder"

NFS-Client

 

root@serv2 [/]#mount serv2:/dump   /dump

nfs mount: serv2: : RPC: Program not registered
nfs mount: retrying: /dump
nfs mount: giving up on: /dump

 

Can anyone help me to trace the problem.

 

Client as well as server are HP-UX 11.31

3 REPLIES
Pete Randall
Outstanding Contributor

Re: HP-UX 11i v3 - 11.31 NFS Mount Issue. RPC: Program not registered

root@serv2 [/]#mount serv2:/dump   /dump

 

Shouldn't that be "mount serv1:/dump /dump"?


Pete
nij
Senior Member

Re: HP-UX 11i v3 - 11.31 NFS Mount Issue. RPC: Program not registered / Device Busy

Sorry, It was my typo error

in fact i tried with the

 

#mount serv1:/dump /dump

 

but i was facing problem with RPC program not registered error,

 

After reading documentation, I found that rpc service was not running on NFS-Server machine. I corrected that

by adding NFS_SERVER=1 parameter and bouncing back nfs.core,nfs.server,nfs.client on NFS-Server machine.

 

Now when I am trying to mount on NFS-Client machine, I am getting another error : Device busy

 

root@serv2 [/]# mount serv1:/dump /dump
nfs mount: /dump: Device busy

Re: HP-UX 11i v3 - 11.31 NFS Mount Issue. RPC: Program not registered / Device Busy

>nfs mount: /dump: Device busy

 

Make sure you or anyone else aren't in the directory /dump.