System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX 11iv2 swcopy dependency errors

SOLVED
Go to solution

HP-UX 11iv2 swcopy dependency errors

I am installing the Dec. 2008 QPK bundle on a model rp7420 HP9000 running 11.23. I am getting the same error for several of the patches The message is similar to:
The corequisite "UserLicense.UNL-USER,fa=HP-UX_B.11.23_IA" for fileset "PHCO_37086.VXVM-RUN,r=1.0" cannot be successfully resolved.
WARNING: The dependencies for fileset "PHCO_37086.VXVM-RUN,r=1.0"
cannot be resolved (see previous lines).
The operation on this fileset will still be attempted even
though there are unresolved dependencies because the
"enforce_dependencies" option is set to "false".
The corequisite "UserLicense.UNL-USER,fa=HP-UX_B.11.23_PA" for
fileset "PHCO_37086.VXVM-RUN,r=1.0" cannot be successfully
resolved.
The corequisite "UserLicense.UNL-USER,fa=HP-UX_B.11.23_IA" for
fileset "PHCO_37086.VXVM-RUN,r=1.0" cannot be successfully
resolved.
WARNING: The dependencies for fileset "PHCO_37086.VXVM-RUN,r=1.0"
cannot be resolved (see previous lines).
The operation on this fileset will still be attempted even
though there are unresolved dependencies because the
"enforce_dependencies" option is set to "false".

Is this a licensing problem? We recently lapsed & renewed on this server. I waited until it was renewed before downloading the bundle (does it matter?). Can I ignore these warnings?
12 REPLIES
Mel Burslan
Honored Contributor

Re: HP-UX 11iv2 swcopy dependency errors

Usually the dependency can not be resolved errors on licensing patches, originates from the lack of the product that is licensed or a wrong version of the product being on the system that what the license is for.

You can always ignore the failed dependencies but at your own peril. I have no checked the patch database for this specific patch you are failing, but from its name, it sounds like it is for VXVM product. If your using LVM, failure of this patch may not be detrimental but if you are using VXVM instead of LVM as logical volume manager, I'd make sure it gets resolved before I apply the patches.
________________________________
UNIX because I majored in cryptology...
Steven E. Protter
Exalted Contributor

Re: HP-UX 11iv2 swcopy dependency errors

Shalom,

Build the patches and any dependencies they have into the patch set and the resolve message will stop happening.

I would use the itrc patch database.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com

Re: HP-UX 11iv2 swcopy dependency errors

Mel,
I am using LVM. swlist shows Base-VXVM 4.1 and BASE-VXFS installed. Most of the warnings (339 out of the 1444 patches) involve CORE2-KRN or CORE2-64SLIB or UX2-CORE, et. al. patches.

swlist also shows product "UserLicense.UNL-USER" (mentioned in all these messages) is installed. Shouldn't the dependency be resolved during the swisntall from the depot?
Dennis Handly
Acclaimed Contributor
Solution

Re: HP-UX 11iv2 swcopy dependency errors

>Shouldn't the dependency be resolved during the swinstall from the depot?

You should always use "-x enforce_dependencies=false" for swcopy but not for swinstall. This defers the checking.
Mel Burslan
Honored Contributor

Re: HP-UX 11iv2 swcopy dependency errors

From my past experience, IPD (Installed Product Database) is a funky animal and sometimes it goes out of whack for no reason. Since you have the base VXVM installed, I must concur with your evaluation of "shouldn't it have passed the dependency check" question. If you have software support agreement with HP, I'd call them up and hear what they say if I were you.
________________________________
UNIX because I majored in cryptology...

Re: HP-UX 11iv2 swcopy dependency errors

Good answers, all, gentlemen [as usual!]. Gives me a few things to try. I have a virtual partition I can test this on, running on a diferent server. The server I got the messages on was one I set up as the Software Depot. I have 3 production servers to install this bundle on after all the bugs are worked out. I think I'll try deleting the depot and re-creating/re-copying with the enforce-dependencies=false and see what that does; then look into the patch database; and/or open a case. Thanks
James R. Ferguson
Acclaimed Contributor

Re: HP-UX 11iv2 swcopy dependency errors

Hi:

If anyone has mucked with the contents of '/var/adm/sw' -- the Installed Product Database (IPD) -- then I agree that things may be amiss for that reason.

Using anything other than the standard SD tools against this directory ('swremove', 'swinstall', 'swmodify' [if you know what you are doing], and/or 'cleanup' to regain space) means that you are asking for trouble!

Before installing anything, I would run:

# swverify \*

While this will take a bit of time, it might be quite informative.

Regards!

...JRF...

Re: HP-UX 11iv2 swcopy dependency errors

Dennis,

FYI: as for enforce-dependencies=FALSE, I ran the script that was supplied with the bundle (create_depot_hpux.11.23) and it does include that option in the swcopy command.
Steven E. Protter
Exalted Contributor

Re: HP-UX 11iv2 swcopy dependency errors

I actually favor having the necessary patches on hand at the swcopy stage.

There is however nothing stopping you from accepting the Dennis suggestion and changing the swcopy options.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Bob E Campbell
Honored Contributor

Re: HP-UX 11iv2 swcopy dependency errors

Good old UserLicense...

That is an unfortunate result of some special hoops we jumped through way back when. It is telling you that something has a dependency on UserLicense but that UserLicense is not in the depot.

Oddly enough, it is *always* on your system so it will be found. The dependency is actually in PHKL_31500 which is also already on your system.

I apologize for the annoyance factor of those messages, but it resolved a real nasty issue. For details come to the 2009 Tech Forum and check the bar stools at Red Square for green Converse sneakers... :-)
Dennis Handly
Acclaimed Contributor

Re: HP-UX 11iv2 swcopy dependency errors

>I ran the script that was supplied with the bundle (create_depot_hpux.11.23) and it does include that option in the swcopy command.

Right. I guess that's why those are warnings.

Re: HP-UX 11iv2 swcopy dependency errors

I am downloading the needed patches and ignoring whatever is already on the system (UserLicense, et. al), and those that are co-resident in the depot.

Thanks for providing a place where it's safe to ask questions.