System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX 11iv3 Installation/Startup Issues HPVM

 
Theodore Jay Allen
Occasional Advisor

HP-UX 11iv3 Installation/Startup Issues HPVM

I have made multiple attempts to get a fresh install of 11iv3 completed with HPVM included in the software selection.

Both attempts have resulted in startup of the HP Virtual Machine Monitor failing and stating that HPSIM-HP-UX is incompatible with HPVM and it must be removed.

My initial install was a complete Data Center installation so it was easier to reinstall than deal with all the dependencies that would prevent removal of the HPSIM-HP-UX bundle so I repeated the install. The second time, I started off with the VSE installation and added some things and removed others. I thought for sure I had avoided the HP SIM related bundles. However, I still get the same error when the HP Virtual Machine Monitor attempts to start. I tried to issue a "swremove -p HPSIM-HP-UX" command after the second install and my session hung.

It also takes an extremely long time for the boot process to complete (startup of the HP Virtual Machine Monitor takes 10 minutes or more to finally log the FAIL* message and startup of sendmail, although it says "Done" quickly, takes up to 10 minutes to finally say "OK" and continue to the next startup item. The same is true for the Veritas Enterprise Administrator Service.

I have an older 11iv2 install with HPVM on a separate disk volume that works normally.

Lastly, I have a monitor connected to the VGA port on the rx2620 where I am performing the 11iv3 install, but I am not using it as the console. After the first installation attempt, at times I would see the "HP Invent" screen splash up, but I never saw the CDE login screen. I have not even seen this screen after the second installation attempt. In both cases I see the following messages on the console terminal:

Starting Desktop login on display ...
Wait for the Desktop Login screen
before logging in.

Sometime later it will say:

Suspending Desktop Login...
Press [Enter] for a login prompt.

After a while it will then say:

Login. Desktop Login will resume
shortly after you log out.

After yet another wait:

Resuming Desktop Login...

This same set of messages repeats over and over. I can get logged into the system in character cell mode on the console and have confirmed that the system is at run-level 3.

Any assistance is greatly appreciated.

Best Regards,

Ted Allen
8 REPLIES
Theodore Jay Allen
Occasional Advisor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

I have resolved most of the issues:

Long delays during boot were resulting
from the lan1 interface being defined but
without the patch cable securely seated.
Apparently this was keeping the first
interface from coming online as well for
some reason because neither interface
responded to a ping. When I unlplugged
the cable on lan0 and plugged it back in
it started responding to pings.

The issue with CDE not coming up was
resulting from the fact that the name
resolution search order was defaulting to
DNS first (/etc/nsswitch.conf did not
exist). Once I created this file with
"files" as the first item in the search
order for "hosts", etc. and restarted
CDE, it came up.

As for HPVM and HP SIM incompatibilty and
FAIL status indicated when HP Virtual
Machine Monitor attempts to start at boot
time, according to HPVM v4 release notes
there is a known problem with HPVM
reporting an error when it starts if HP
SIM is installed. It supposedly still
comes up and is functional. I still have
to confirm this.

Best Regards,

Ted Allen
Jozef_Novak
Respected Contributor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

Hello,

as per HP SIM installation guide, SIM cannot be installed on an Integrity VM host. Hence the problem you are encountering.

Jozef
Theodore Jay Allen
Occasional Advisor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

Hello Jozef,

Thanks for the reply. According to the HPVM 4.0 Release Notes, it looks like it is ok to have HP SIM installed on the HPVM host, however, a warning message will appear during startup and the VM Monitor will still start.

I have successfully created a VM (SLES 10) with HPVM 4.0 and HP SIM both installed. I have another thread open to address questions/issues with the operation of the VM Guest.

I can't find anything that says that HP SIM can no longer be installed with HPVM.

Best Regards,

Ted Allen
Tingli
Esteemed Contributor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

How about your net work connection?
Jozef_Novak
Respected Contributor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

Hello Theodore,

yes you are right, HPVM 4.0 release notes state that *only* warning is displayed when HPVM attempts to start on a host with SIM installed.

However, for example if you attempt to install HPVM on a system where SIM is already installed, the installation fails. Also SIM installation guide states that HP SIM CMS cannot run on a VM host. Although the manuals suggest incompatibility "one way only", based on the above, I would either remove SIM software from the VM host or choose a different system for HPVM instead.

Regards,
Jozef
Harris Mir
Frequent Advisor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

I have a problem that kind of resembles what you had.

My re-conditioned C3700 is supposed to run hp-ux 11.0.

On very first power up, it went through various screens and setups, it asked me to set a user name and password.

Then it takes me to a "CDE login screen". From the documentation, I realise that I am supposed to login as "root", so I try username=root and the password that i set during setup.

The screen goes blank and the hourglass cursor appears. Then the CDE login window comes back asks me for my username. I repeat the process still no change.

I even managed to change my password (in case I had mistyped during setup) by interrupting the boot sequence when I restarted. Still it does the same thing.

Anybody have any ideas?

I am not even a novice when it comes to UNIX so bear with me if this is school boy stuff. Thanks
Tingli
Esteemed Contributor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

Does your server have network connection?
Rita C Workman
Honored Contributor

Re: HP-UX 11iv3 Installation/Startup Issues HPVM

First....Harris,

It could be a number of things from the graphics card, but I'm going to suggest resolution.

Reboot, interupt boot and go into single user mode:
> Interupt boot
> bo pri isl
Interact w/ISL > yes
ISL > hpux -is
manually mount /usr & /var
Then go in and ensure that:
/etc/resolv.conf has correct info
Ex: search
nameserver
nameserver
/etc/nsswitch.conf has correct info
Make the host line look like this to resolve to hostfile first, then check DNS
hosts: files {NOTFOUND=continue] dns
/etc/hosts has correct info
You want at least loopback line
127.0.0.1 localhost



Then try to reboot it and see if you get any farther.

Oh & Harris...you could open your own thread for this and assign points. Or you could do a search "cde not working", cause this happens to plenty of folks. So if resolution doesn't help - try the search.

========================================
Second....TED!

I'm having some really annoying issues with the same scenario. HP-SIMM on box that I am trying to get HPVM (mine is version 4.1) loaded on.

If I can get this fixed and working, I'll let you know. Cause right now the box is totally hosed up and I'm trying to rebuild it from a recovery tape.

You are not alone!

Rgrds,
Rita