cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX Patch installation

pymsh
Frequent Advisor

HP-UX Patch installation

Hi,
I want to install some patches as pre-installation for oracle 11g on HP-UX 11i V2 (11.23):

- PHSS_35176: For HP C/ANSI C Compiler
- PHSS_35101: For HP C/ANSI C Compiler
- PHSS_35103: For HP C/ANSI C and HP aC++ compilers
- PHSS_35102: For HP aC++ Compiler

But i see this error:

The patch fileset "PHSS_35101.C,r=1.0" may only be installed upon a previously installed base fileset. The specification for this base fileset is "C-ANSI-C.C,fr=B.11.23.11,v=HP".
Since there is no fileset on the target or selected from the source which matches this specification, fileset "PHSS_35101.C,r=1.0" will be excluded.

Each patch from these 4 patches sends a error message same above and i can't install these.
How can i resolve this problem?
Any help will be appreciated.
10 REPLIES
Duncan Edmonstone
Honored Contributor

Re: HP-UX Patch installation

you can not install the pacthes...

these patches are for the HP C/C++ compilers which you apparently don't have installed - you don't need these patches installed for Oracle unless you are planning to create Oracle ProC or ProC++ programs, in which case you would need a HP compiler.

so ignore the messages from the Oracle Installer or release notes and just install Oracle without these patches.

this issue comes up about twice a week on here - one would think that Oracle would update thie installer/documentation...

HTH

Duncan

HTH

Duncan
Vivek_Pendse
Valued Contributor

Re: HP-UX Patch installation

Please check the swlist -l fileset | grep -i compiler.
If the core compiler is present, then only the patches can be installed.

Regards,
Vivek
pymsh
Frequent Advisor

Re: HP-UX Patch installation

Hi Vivek
I executed "swlist -l fileset | grep -i compiler", and got this response:

#COMPLIBS B.11.23 Compiler Support Librarys
#PHCO_31664 1.0 Japanese linker/compiler

I think i don't have C++ Compiler installed and the message comes from it.
If so, how can i install it?
Thanks.
Vivek_Pendse
Valued Contributor

Re: HP-UX Patch installation

You need to have the Compiler. These patches will be only installed if you have the compilers for them are installed.
pymsh
Frequent Advisor

Re: HP-UX Patch installation

Hi again Vivek,
Should i install from HP-UX DVD?
Which package does contain this compiler?
Thanks.
Vivek_Pendse
Valued Contributor

Re: HP-UX Patch installation

It's a license product. You need a codeword with customer id for it to install.
Tingli
Esteemed Contributor

Re: HP-UX Patch installation

No, you don't need to install those patches as they are just for developers. Although there will be warning during Oracle installation, but it won't affect the installation.
Vivek_Pendse
Valued Contributor

Re: HP-UX Patch installation

Hi,

I guess, the question was asked for the patch installation not for the oracle installation.
I believe, if it's oracle12g, then it will require Compiler, cannot ignore while doing the installation.
One more option is there to install the evaluation version of Compiler (time being) till you get the permanent license.

Regards,
Vivek
Dennis Handly
Acclaimed Contributor

Re: HP-UX Patch installation

>How can I resolve this problem?

By ignoring the incomplete documentation to install obsolete patches. The correct info should include mention of what Duncan said about ProC. And mention that if you have a newer version of the compilers, you should also ignore those patches.

>Should I install from HP-UX DVD?

It isn't present there. Only on the Application CD, with a codeword/license.

>Vivek: If the core compiler is present, then only the patches can be installed.

It is more specific than that. You must have a particular obsolete version of the compiler.

>if it's oracle12g, then it will require compiler, cannot ignore while doing the installation.

Not likely. Installation only requires the bundled C compiler.

>One more option is there to install the evaluation version of Compiler (time being) till you get the permanent license.

No need, unless you plan to develop applications.

Vivek_Pendse
Valued Contributor

Re: HP-UX Patch installation

Thanks..