cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX Secure Shell

SOLVED
Go to solution
Kusado
Frequent Advisor

HP-UX Secure Shell

I woder if i'm able to install the latest version of SecureShell having an HP-UX В.11.00 installed on my server. As i can understand the latest version of software requires at least 11i v1.
tnx
7 REPLIES
Johnson Punniyalingam
Honored Contributor

Re: HP-UX Secure Shell

Of course it probably will not run binaries that were compiled for 11.11
Problems are common to all, but attitude makes the difference
Johnson Punniyalingam
Honored Contributor

Re: HP-UX Secure Shell

http://mirrors.develooper.com/hpux/downloads.html#hpux1100
Problems are common to all, but attitude makes the difference
Matti_Kurkela
Honored Contributor
Solution

Re: HP-UX Secure Shell

No you can't. The version requirement is encoded within the depot, and swinstall will just refuse to install it.

If you install the latest Secure Shell to an 11i v1 machine, then copy the binaries to an 11.00 machine, you'll find that the Secure Shell requires system library versions & library functions that 11.00 simply does not have. So it won't work.

The last HP Secure Shell version with 11.00 support was A.04.30.014. By now, a considerable number of bugs has been found from that version. Instead of looking for the old version, you're much better off compiling the latest version yourself from the source package.

http://hpux.connect.org.uk/hppd/hpux/Networking/Admin/openssh-5.3p1/

As you're running an obsolete and unsupported version of HP-UX, you should be prepared to compile your own software if you wish to keep using 11.00.

If you wish to upgrade to 11i v1, do not delay: the End-Of-Sales date for 11i v1 is 31-December-2009.

MK
MK
Kusado
Frequent Advisor

Re: HP-UX Secure Shell

Is this http://mirrors.develooper.com/hpux/openssh-4.0p1-11.00.sd.bz
the exact version of software i'm looking for?
Or plz tell me about the process of installing the most current version from sources? (I wish there were some step-by-step instructions)...
Ganesan R
Honored Contributor

Re: HP-UX Secure Shell

Hi Kusado,

Try here...

http://www.cmve.net/merijn/downloads.html#hpux1100
Best wishes,

Ganesh.
Kusado
Frequent Advisor

Re: HP-UX Secure Shell

I didn't catch any difference between those links
(
http://www.cmve.net/merijn/downloads.html#hpux1100
http://mirrors.develooper.com/hpux/downloads.html#hpux1100
)
I'm not quite sure about what link inside of that pages I'd use... Maybe "OpenSSH 4.0p1"? Or "OpenSSL 0.9.7d". They both are not similar with "A.04.30.015" for me...
Steven E. Protter
Exalted Contributor

Re: HP-UX Secure Shell

Shalom,

Your options are to either download it from Merijn, ore compile it yourself from http://www.openssh.org

Compiling is not going to be an easy task because you may need other software that is no longer available for HP-UX 11.00

If you have the Application CD's handy, there may be an old, insecure version of secure shell lying about.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com