cancel
Showing results for 
Search instead for 
Did you mean: 

HPASM on Debian (lenny)

Yasen Vladimirov
Occasional Visitor

HPASM on Debian (lenny)

Hello all,

I have problems installing the hpasm deb on the newly installed Debian with lenny packages. I have downloaded the Debian packages for Etch, I have tried to install the hp-OpenIPMI but no luck I get this error :

--------------------------------------
dpkg: ... it looks like that went OK.
Setting up hp-openipmi (7.8.0-108.etch26) ...
chmod: cannot access `/opt/hp/hp-OpenIPMI': No such file or directory
chmod: cannot access `/opt/hp/hp-OpenIPMI/bin': No such file or directory
ln: creating symbolic link `/opt/hp/hp-OpenIPMI/Makefile': No such file or directory
sh: /opt/hp/hp-OpenIPMI/check_install_kernel.sh: No such file or directory
Please read the Licence Agreement for this software at

/opt/hp/hp-OpenIPMI/COPYING
and
/opt/hp/hp-OpenIPMI/hp-OpenIPMI.license

By not removing this package, you are accepting the terms
of the included licenses.

The man page, hp-OpenIPMI(4), describes how enable and use
the hp-OpenIPMI device drivers.


-------------------------


Actually I am pretty sure that it because the kernel is not the one that is stock with Etch.
On other hand I have 6 RHEL5 servers and I can monitor them without any problem. On this debian I only can see the cpu stats via cacti, no temperature info no controller info :(
4 REPLIES
Yasen Vladimirov
Occasional Visitor

Re: HPASM on Debian (lenny)

No one :(
Matti_Kurkela
Honored Contributor

Re: HPASM on Debian (lenny)

Do you have an /opt directory in your system? Is it writable?

This does not look like a kernel-related problem: it's more like the installer could not place the files in the location they're supposed to go to.

Or maybe the package assumes that /opt/hp is already created by some other package, and cannot create it on its own if it does not exist? In this case, make sure that the directory /opt/hp exists before trying to re-install the package.

MK
MK
Steven E. Protter
Exalted Contributor

Re: HPASM on Debian (lenny)

Shalom,

Is your exact release of Debian on the certification list for HPASM. If not, this dog is not going to hunt.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Yasen Vladimirov
Occasional Visitor

Re: HPASM on Debian (lenny)

Yes my version is not listed :( This is the most recent version of Debian