System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSMH 3.2.8 gives certificate errors; running hp-ux 11.31

NavyYard
Valued Contributor

HPSMH 3.2.8 gives certificate errors; running hp-ux 11.31

Hi!

 

Although hpsmh is up and accessible on my hpux 11.31 running on the Blade, it gives certificate errors on the web page. Nessus scan is complaining about the expired certificate in hpsmh and raises flag.

 

Is there a way to regenerate/refresh the certificate?

 

I tried regenerating iy using the following command but it did not help:

 

swconfig -x reconfigure=true SysMgmtHomepage

 

 

Looking at the certificate, it shows it is valid until 2015.

 

Please advice if you can. Thanks

3 REPLIES
Dennis Handly
Acclaimed Contributor

Re: HPSMH 3.2.8 gives certificate errors; running HP-UX 11.31

>Looking at the certificate, it shows it is valid until 2015.

 

When in 2015?  Did it expire recently?

NavyYard
Valued Contributor

Re: HPSMH 3.2.8 gives certificate errors; running HP-UX 11.31

Hi Dennis!

 

When I installed hpsmh, smh also generated a proper certificate for the service. So, I reinstalled hpsmh but scanning still sees the certificate error. Host where hpsmh is stalled is accessible only on the internal network and buying a certificate is not a need, I just need this Cert error message to go away. So, I ran swconfig as it will refresh the certificate but it did not help.

 

Thanls

Dennis Handly
Acclaimed Contributor

Re: HPSMH 3.2.8 gives certificate errors; running HP-UX 11.31

>I reinstalled hpsmh but scanning still sees the certificate error.

 

Where have you looked for the expired certificate?  Does the error message say where it is?

 

>smh also generated a proper certificate for the service. 

 

Where is this one?