System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HPSMH problems on Debian (squeeze in my case, but also lenny)

mstar-fk
Occasional Visitor

HPSMH problems on Debian (squeeze in my case, but also lenny)

Hi!

I discovered to my shock that installing the HPSMH tools (from the .deb) overwrite ld.so.conf (!) with a directory, in there it places a ld.so configuration file with its own private version of system libraries (openssl, libcrypto) which are old and do not include version numbers (!).

The HPSMH package also claims to own /usr/local (!)

The cpqacuxe package has a dependency on hpsmh. Thankfully we do not need cpqacuxe on most machines and can avoid these problems there. On the machines with an array controller we need to use the BIOS instead.

The hpsmh package also does not have correct dependencies -- it seems to require php5 and sudo.

All of this will require fixing before a Squeeze .deb is released.


Frank