System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HPUX 11.31 -net-snmp responds to queries only localhost

benzure
Occasional Visitor

HPUX 11.31 -net-snmp responds to queries only localhost

Hi,

 

we installed Net-SNMP on a HPUX 11.31 server in addition to the HP SNMP.
We followed the following link: http://administratosphere.wordpress.com/2009/06/09/using-net-snmp-and-hp-ux-snmp-together/

 

Both daemons are running on two different ports
161 HP snmp
166 Net-SNMP

 

 

netstat -an | grep 166
udp        0         0               *.166           *.*
udp        0         0               *.166           *.*

 

netstat -an | grep 161
tcp        0          0            127.0.0.1.7161             *.*           LISTEN
udp       0         0            *.161                                   *.*

 

SNMP request with snmpwalk runs on port 161 and 166 from the HPUX server (localhost)

 

 

/sbin/init.d> snmpwalk -m ALL -v 2c -c public localhost .1
SNMPv2-MIB::sysDescr.0 = STRING: HP-UX SVWH-TEL B.11.31 U ia64 3863421436
SNMPv2-MIB::sysObjectID.0 = OID: SNMPv2-SMI::enterprises.11.2.3.2.6
DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (33961) 0:05:39.61
SNMPv2-MIB::sysContact.0 = STRING:

.......

 

 

 

/sbin/init.d> snmpwalk -m ALL -v 2c -c public localhost:166 .1
SNMPv2-MIB::sysDescr.0 = STRING: HP-UX SVWH-TEL B.11.31 U ia64
SNMPv2-MIB::sysObjectID.0 = OID: NET-SNMP-TC::hpux11

.......

 

 

But if we do a snmpwalk on port 166 from a remote server,we have a failure:


snmpwalk-m ALL-v 2c-c public-svwh telnetvig 166 .1
Timeout: No Response from svwh-telnetvig: 166

 

 

But snmpwalk on port 161 works


  snmpwalk-m ALL-v 2c-c public-svwh telnetvig .1
SNMPv2-MIB :: sysDescr.0 = STRING: HP-UX B.11.31 U-TEL SVWH ia64 3863421436
SNMPv2-MIB :: sysObjectID.0 = OID: SNMPv2-SMI :: enterprises.11.2.3.2.6
Disman-EVENT-MIB :: = sysUpTimeInstance Timeticks: (293232) 0:48:52.32
SNMPv2-MIB :: sysContact.0 = STRING:

......

 

In the log of the HPUX server during the test snmpwalk on port 166 we have the following message:

Received SNMP packet(s) from UDP: [10.4.96.11]:51395->[0.0.0.0]:0

 

10.4.96.11 is  HPUX IP.

 

Here is the configuration of my snmpd.conf file for Net-SNMP:

 

####
# First, map the community name "public" into a "security name"

# sec.name source community
com2sec notConfigUser default public

####
# Second, map the security name into a group name:

# groupName securityModel securityName
group notConfigGroup v1 notConfigUser
group notConfigGroup v2c notConfigUser

####
# Third, create a view for us to let the group have rights to:

# Make at least snmpwalk -v 1 localhost -c public system fast again.
# name incl/excl subtree mask(optional)
view systemview included .1.
view systemview included .1.

 

 

why net-snmp works only in localhost while HP SNMP works fine on the LAN?

The aim is to use net-snmp for SNMP queries from the PRTG tool

 

 

Thank you for your answers

 

4 REPLIES
Matti_Kurkela
Honored Contributor

Re: HPUX 11.31 -net-snmp responds to queries only localhost

Your snmpd.conf is missing the "access" lines that would tie the groups and the views together.

MK
benzure
Occasional Visitor

Re: HPUX 11.31 -net-snmp responds to queries only localhost

Sorry 

 

in attachements , the snmp.conf 

Re: HPUX 11.31 -net-snmp responds to queries only localhost

I was having the same problem...  Ended up removing that version (5.7) and installing the binaries I found for HP-UX 11.11 (net-snmp-5.4-1-HP-UX_B.11.11_9000_800.tar.gz).  These worked for me.

 

Good luck!

 

Hil

Ribaud
Collector

Re: HPUX 11.31 -net-snmp responds to queries only localhost

Hello,

 

After spending severals hours on the topic to understand why Net-SNMP smtpd only works on localhost.

 

I found the following note on the iexpress download main page and also thanks to the above comments.

 

Note for Net-SNMP product

There is a known issue with snmpwalk tool delivered with the Net-SNMP 5.7.2 version.

In certain scenarios snmpwalk fails with the “Destination unreachable” error.

To work around this issue, please download Net-SNMP 5.6.1 and configure it.

 

Despite the issue description does not look like mine, after downgrading and installing Net-SNMP 5.6.1, it works in a couple of minutes.

 

Note : Net-SNMP 5.6.1 is proposed later in the download process of iexpress suite download.

 

Regards.

René.