cancel
Showing results for 
Search instead for 
Did you mean: 

HPUX11.23:SVN Install Error

Nido
Trusted Contributor

HPUX11.23:SVN Install Error

Hi,

I have installed svn_1.6.9 (http://hpux.connect.org.uk/hppd/hpux/Development/Tools/subversion-1.6.9/) and it works fine.

SVN supports two methods of specifying user names and passwords to commands:
1. Use the --username and --password arguments
2. Allow SVN to prompt the user

The second option is strongly preferred because option 1 displays the Password on the command line.

Unfortunately, there appears to be an 8 character limitation with the getpass() function on HP-UX. As a result, option 2 only works if the passwords are of 8 characters less. This situation is definitely not ideal.

The following links suggest a possible fix involving APR on the HP-UX system.

http://svn.haxx.se/users/archive-2004-09/0127.shtml

http://osdir.com/ml/apache.apr.devel/2004-12/msg00011.html

http://svn.haxx.se/users/archive-2006-08/1246.shtml

https://issues.apache.org/bugzilla/show_bug.cgi?id=40256

After removing the APR_0.9.18 and apr_util_0.9.17 and installing APR_1.4.2 and APRUtils_1.3.9 from the source, I'm getting error:

Error:
/usr/lib/hpux32/dld.so: Unable to find library 'libaprutil-0.so'.
Killed


I don't see libaprutil-0.so available after installing APR_1.4.2 and APRUtils_1.3.9.


Please help me fix the issue of 8-char password limit in SVN.


Thanks,
P.Naidu
" Let Villagers Be Happy!! "
5 REPLIES
Steven E. Protter
Exalted Contributor

Re: HPUX11.23:SVN Install Error

Shalom,

There is a substantial pre-requisite list to this software: http://hpux.connect.org.uk/hppd/hpux/Development/Tools/subversion-1.6.9/

Are they all installed.

That site has a new (to me) toy called depothelper. depotholper works a lot like yum and handles the dependencies for you.

http://hpux.connect.org.uk/hppd/hpux/Sysadmin/depothelper-2.00/


SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Nido
Trusted Contributor

Re: HPUX11.23:SVN Install Error

Hello SEP,

I had working svn with all dependencies.

To fix 8 char password limit, I removed APR_0.9.18 and apr_util_0.9.17.

And installed APR_1.4.2 and APRUtils_1.3.9 from the source (http://apr.apache.org/download.cgi) which should have fixed the issue by by-passing getpass() function.

I checked the apr-0.9.18-ia64-11.23.depot contents and found libaprutil-0.so under apr/apr-RUN/usr/local/apr/lib.

But just wondered why the same shared-libs (libaprutil-0.so ) is missing in APR_1.4.2.

Or Do I need to install SVN and all its dependencies from the Source to get working SVN including libaprutil-0.so ??

Thanks,
P.Naidu

" Let Villagers Be Happy!! "
KathyK
Regular Advisor

subversion binary (client) for hp-ux11.23

Hi,

 

I have installed the newest available svn client which is subversion 1.6.17 for hp-ux11.23. Also installed all the run time dependencies.

Here is the problem I'm having and was wondering if anyone has seen it and or resolved it.

 

a full check out of the repository core dumps:

 

svn co      <my url to repository>

A    trunk/cell
A    trunk/cell/kanbanYield.p
A    trunk/cell/bfSubconRecv.p
A    trunk/cell/traceIDMstr-r.r
A    trunk/cell/kanbanYield.r
A    trunk/cell/itemAllocKanban.p
A    trunk/cell/itemAllocKanban.r
A    trunk/cell/aggBomRunRate.i
A    trunk/cell/updCoq.p
A    trunk/cell/aggBom.p
A    trunk/cell/dataclnRpt.p
A    trunk/cell/updCoq.r
A    trunk/cell/aggBom.r
A    trunk/cell/dataclnRpt.r
A    trunk/cell/verifyKanbanItem.p
A    trunk/cell/verifyKanbanItem.r
A    trunk/cell/aggBomVendor.i
A    trunk/cell/getTraceRcvdRec.p
A    trunk/cell/getTraceRcvdRec.r
A    trunk/cell/kb-parms-rpt.p
A    trunk/cell/kb-parms-rpt.r
A    trunk/cell/getBrdLocItem.p
A    trunk/cell/cellWipRpt.p
A    trunk/cell/getBrdLocItem.r
A    trunk/cell/disAssemblyGuess.p
A    trunk/cell/unCompleteKanban.p
A    trunk/cell/cellWipRpt.r

Program received signal SIGSEGV, Segmentation fault.

 

And this is the result of what core cmmand:

 

n4000:root:/users/kkhagani/simsrc>what core
core:
         1.1SCCS/s. 08/21/01 14:10:37
         UNIXDS.i
         $Id: disAssemblyGuess.p 7434 2011-09-28 23:59:56Z glenn $ UNIX cell/disAssemblyGuess.p
         $Id: disAssemblyDS.i 7434 2011-09-28 23:59:56Z glenn $ UNIX cell/disAssemblyDS.i
         $Id: eMsgs.i 4603 2010-05-19 17:12:07Z glenn $ UNIX lib/eMsgs.i
         $Id: disAssemblyGuess.p 7434 2011-09-28 23:59:56Z glenn $ UNIX cell/disAssemblyGuess.p
         $Id: disAssemblyDS.i 7434 2011-09-28 23:59:56Z glenn $ UNIX cell/disAssemblyDS.i
         $Id: eMsgs.i 4603 2010-05-19 17:12:07Z glenn $ UNIX lib/eMsgs.i
         1.1 /users/simsrc/cell/SCCS/s.unCompleteKanban.p 07/25/06 09:50:00 {&opsys} {0}
         1.1 /users/simsrcSCCS/s. 03/20/08 p
         1.1 /users/simsrc/cell/SCCS/s.kb-parms-rpt.p 08/21/01 14:10:37 cell/kb-parms-rpt.p
         1.1 /users/simsrc/cell/SCCS/s.itemAllocKanban.p 03/20/08 p cell/itemAllocKanban.p
         $Id:.i 2225 2011-03-05 01:34:52Z svnadmin $ UNIX lib/1.17 /users/sytesource/modsim/help/SCCS/s.debug.i 02/09/07 11:14:37 webspeed.i 397809 23:46:38Z glen
         $Id: sendEmail.i 2225 2011-03-05 01:34:52Z svnadmin $ UNIX lib/sendEmail.i
         1.17 /users/sytesource/modsim/help/SCCS/s.debug.i 02/09/07 11:14:37 help/debug.i
         $Id: webspeed.i 3978 2010-03-09 23:46:38Z glenn $ UNIX lib/webspeed.i
         1.4 /users/simsrc/util/SCCS/s.list.i 10/24/06 10:08:07 util/list.i
         $Id: aggBom.p 592 2009-06-03 16:53:26Z glenn $ UNIX cell/aggBom.p
         1.4 /users/simsrc/util/SCCS/s.list.i 10/24/06 10:08:07 util/list.i
         1.17 /users/sytesource/modsim/help/SCCS/s.debug.i 02/09/07 11:14:37 help/debug.i
         1.8 /users/simsrc/lib/SCCS/s.webspeed.i 12/09/03 17:45:48 UNIX lib/webspeed.i
         1.3 /users/simsrc/lib/SCCS/s.warn.i 01/31/02 16:10:13 UNIX lib/warn.i
         $ B.11.23  Aug 16 2004 13:50:34 $
        HP-UX libm shared PA1.1 C Math Library 20040526 (142440)   UX11.23
         $ PATCH_11.23/PHCO_40571  Mar 15 2011 08:34:23 $
         SMART_BIND
        92453-07 dld dld dld.sl B.11.72 110608

 

 

I can supply any other information needed. I've been working three days to get this resolved and it's becoming a very hot subject, your help will be greatly appreciated.

 

Best Regards,

kathy

 

Dennis Handly
Acclaimed Contributor

Re: subversion binary (client) for HP-UX 11.23

>Program received signal SIGSEGV, Segmentation fault.

 

Please use gdb's bt to get a stack trace and register dump:

(gdb) bt

(gdb) info reg

(gdb) disas $pc-4*12 $pc+4*8

KathyK
Regular Advisor

Re: subversion binary (client) for HP-UX 11.23

Dennis,

 

Thank you for your fast reply. I was able to get the following info, before i removed that version of svn.

 

gdb) bt

#0  0xc00a36d8 in ?? () from /usr/lib/libpthread.1

#1  0xc30a1014 in ?? () from /usr/local/apr/lib/libapr-0.sl

#2  0xc30973cc in ?? () from /usr/local/apr/lib/libapr-0.sl

#3  0xc30956f8 in ?? () from /usr/local/apr/lib/libapr-0.sl

#4  0xc86441ac in ?? () from /usr/local/lib/libsvn_subr-1.sl

#5  0xc8641360 in ?? () from /usr/local/lib/libsvn_subr-1.sl

Cannot read instruction at 0x0.

(gdb)

 

 

i will get the rest as soon as I have another core dump.

 

thank you again

 

Kathy