HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HPUx 11.11 file system does not mount after reboot, works manually

 
SOLVED
Go to solution
vz7r1x
Regular Advisor

HPUx 11.11 file system does not mount after reboot, works manually

Hi,
I created a file system using SAM but it does not get mounted after reboot.

/etc/fstab shows the following:
/dev/vg05/lvol0 /audit vxfs delaylog,nodatainlog,largefiles,rw,suid 0 2


HOST>mount -v
/dev/vg05/lvol0 on /audit type vxfs log,nodatainlog on Wed Jul 7 10:40:48 2010


HOST> bdf /audit
Filesystem kbytes used avail %used Mounted on
/dev/vg05/lvol0 314523648 23966560 288287176 8% /audit

HOST> vgdisplay vg05
--- Volume groups ---
VG Name /dev/vg05
VG Write Access read/write
VG Status available
Max LV 255
Cur LV 1
Open LV 1
Max PV 16
Cur PV 1
Act PV 1
Max PE per PV 19199
VGDA 2
PE Size (Mbytes) 16
Total PE 19197
Alloc PE 19197
Free PE 0
Total PVG 0
Total Spare PVs 0
Total Spare PVs in use 0


Only way to mount it is manually:

mount /dev/vg05/lvol0 /audit

Please suggest solutions if I am mounting it incorrectly.

Thanks
7 REPLIES
Patrick Wallek
Honored Contributor

Re: HPUx 11.11 file system does not mount after reboot, works manually

Check /etc/rc.log and see if there is an error logged there. If so, please report back with the error.

What you have posted looks good. Without knowing the precise error, it is difficult to troubleshoot.
vz7r1x
Regular Advisor

Re: HPUx 11.11 file system does not mount after reboot, works manually

Thanks for the reply.

Here is the output from /etc/rc2.log

----------------------------
mountall: cannot mount /dev/vg05/lvol0
mountall: diagnostics from mount
vxfs mount: mount option(s) incompatible with file system /dev/vg05/lvol0
checking quotas

Update kernel and loadable modules
Output from "/sbin/rc1.d/S110kmbuild start":
----------------------------

Thanks
Patrick Wallek
Honored Contributor
Solution

Re: HPUx 11.11 file system does not mount after reboot, works manually

OK, the error is:

>>vxfs mount: mount option(s) incompatible with file system /dev/vg05/lvol0

This likely means that your file system is NOT actually largefiles capable.

Check it with this command:

# fsadm /audit

If it returns "nolargefiles" then you need to do 1 of 2 things:

1) Modify /etc/fstab to read "nolargefiles" for this file system.

2) Modify the file system so that it is largefiles capable. If you have online JFS this can be easily done with the command: "fsadm -o largefiles /audit"

Once either of these is done, your filesystem should mount automatically when the system boots.
vz7r1x
Regular Advisor

Re: HPUx 11.11 file system does not mount after reboot, works manually


Thanks Pat.

fsadm shows that file is "nolargefiles". I have updated fstab to reflect the correct mount command format.

fsadm /audit
fsadm: /etc/default/fs is used for determining the file system type
nolargefiles

Thank you.

Re: HPUx 11.11 file system does not mount after reboot, works manually

Or modify /etc/fstab to leave out "largefiles" for this file system.
vz7r1x
Regular Advisor

Re: HPUx 11.11 file system does not mount after reboot, works manually


Thanks Dennis.

Instead of updating /etc/fstab and change largefiles to nolargefiles, I ran "fsadm -o largefiles /audit". This way, I will be able to store files over 2Gb in size.

Thanks
Patrick Wallek
Honored Contributor

Re: HPUx 11.11 file system does not mount after reboot, works manually

A note of clarification for future readers:

If you omit nolargefiles/largefiles from the /etc/fstab, then the file system will mount in the mode it was created with. This way you do not have to worry about specifying the option in /etc/fstab.