System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

 
David G. Douthitt
Regular Advisor

HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

Apparently, VMAGENT, VMCONVERT, and VMMIGRATE are all installed - but HPVM just refuses.

Installing from the Sept. 2008 update of HP-UX 11i v3 results in a "Bad Address (14)" error during installation.

Copying to /var/spool/sw with swcopy works fine (after removing dependency checks). Installing from /var/spool/sw results in "The software selection HPVM.HPVM-CORE,... is not available. Make sure its state is "AVAILABLE"."

What is wrong? I'll probably remove the bits of this bundle that are installed and try again, but I'm not convinced that'll work. Any other suggestions?
10 REPLIES
Torsten.
Acclaimed Contributor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

Is your core OS already on version september 2008?

Read the swlob log for error messages - I recently found something like "you cannot install product abc if product def is already installed ...".

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
David G. Douthitt
Regular Advisor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

I saw some of those: it related to the fact that vPars could not be installed if Integrity VMs were installed. I thought I took care of all those; will look again for more.
David G. Douthitt
Regular Advisor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

I didn't see anything like what was described. Attempting to reinstall had no effect on the installation process (nor on the errors produced).

Attempting to remove VPAR-CORE actually wants to remove vmKernel - that is removing vPar support from the kernel removes Integrity VM support as well.

The error message refers to /opt/hpvm as its status being unavailable (instead of AVAILABLE). Searching for /opt/hpvm in the current installed base shows it owned by vmKernel.

What gives? This is so frustrating!
David G. Douthitt
Regular Advisor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

I noticed this bundle:

HPUX11i-DC-OE B.11.31.0809 HP-UX Data Center Operating Environment

This matches what is on the DVDROM.
melvyn burnard
Honored Contributor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

Hmm, are you trying to install this as a separate install from the media?
I suspect you may be hitting a known issue:
2.1.1 Installing Integrity VM V4.0 As Independent Product Fails
If you try to install Integrity VM V4.0 independently (that is, not as part of or in conjunction with
the OE), then the installation fails. There are two basic reasons for the failure:
â ¢ Installing T2767BC from DVD #1 fails, because the bundle is not on DVD #1
â ¢ Installing T2767BC from DVD #2 fails, because its prerequisite (VMKernelSW) is not on
DVD #2.
To work around this problem, follow these steps:
1. Install VMKernelSW from DVD #1.
#swinstall -x autoreboot=true -s DVD #1 VMKernelSW
2. Install T2767BC from DVD #2.
#swinstall -x autoreboot=true -s DVD #2 T2767BC


See page 23 of http://docs.hp.com/en/T2767-90179/T2767-90179.pdf and try this procedure
My house is the bank's, my money the wife's, But my opinions belong to me, not HP!
David G. Douthitt
Regular Advisor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

VMKernelSW is already installed:

# swlist -l bundle | grep -i vmkernelsw
VMKernelSW B.04.00 Integrity VM Kernel Software

The problem still occurs when trying to install T2767BC.
Umesh L
Occasional Visitor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

Hi,

As Torsten said, make sure all latest OS patches and related OS bundle installed on the system before installing HPVM 3.5/HPVM 4.0 as it looks for some specific os bundle during installation. Please check below URl for minimal requirement to install HPVM 4.0
http://www.docs.hp.com/en/T2767-90141/index.html

Umesh
Ricardo Soto
Occasional Visitor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

Hi David,

Check the base_pagesize kernel parameter:

# kctune base_pagesize

If it is 64, change it to 4, reboot and install, then change it back to 64.
David G. Douthitt
Regular Advisor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

I reinstalled HP-UX 11i v3 from scratch using the September 08 Update release; all works now.

This marks the second time that HP-UX upgrades (update-hpux) didn't work - and in both cases, a reinstall worked beautifully.
David G. Douthitt
Regular Advisor

Re: HPVM (part of T2767BC Integrity VM Bundle) refuses to install (HP-UX 11i v3)

Closing thread.