cancel
Showing results for 
Search instead for 
Did you mean: 

Heap Space error

SOLVED
Go to solution
Joan Shannon
Occasional Visitor

Heap Space error

We're running Tru64 Unix 4.0d. We've had heap space errors and the following in the alert.log when updating a database:
04030, 00000, "out of process memory when trying to allocate %s bytes (%s,%s)"
// *Cause: Operating system process private memory has been exhausted
// *Action:

The .dat file is over 2,3Gb & when split runs successfully. We've increased the memory on the server from 1Gb to 2Gb but are still receiving the errors.

When run on our test server it runs successfully. The server is exactly the same except it has a total of 4Gb memory.

Checked the sysconfig files and the only differences are
prod test
sem_mni 256 16
num_of_sems 200 400

Any ideas? Are there settings I need my DBA's to change in order for it to 'see' the memory???
6 REPLIES
Erich Wimmer
Valued Contributor
Solution

Re: Heap Space error

I believe you have to change your sysconfig settings. For example, try "sysconfig -q proc" to see your process-space limits.
You could change these parameters with the GUI dxkerneltuner, or with help of "sysconfigdb". Your database provider should give you the recommended values.
Erich.
Johan Brusche
Honored Contributor

Re: Heap Space error

Joan,

You will have to look into per-proc-data-size, per-proc-address-space and vm-maxvas.
To check current values, use:

sysconfig -q proc | grep -e size -e space
sysconfig -q vm vm-maxvas

To increase use the sysconfigdb command to increase corresponding values in /etc/sysconfigtab.

A reboot is required to make the changes actif.

Johan

~_~

_JB_
Joan Shannon
Occasional Visitor

Re: Heap Space error

Thanks for your quick replies - much appreciated.

The sysconfig file doesn't contain any settings for proc-data-size, proc-address-space or vm-maxvas yet the Test server does (at 2147483248).

We've alot of redtape to go through in order to get these settings changed & to reboot the server. I'll let you know if we're successful.

Do you think its correct that the 4Gb Test server is also set at 2147483248? Or should it be higher?
Hein van den Heuvel
Honored Contributor

Re: Heap Space error



Yeah, well, you'll just have to bite the bullet. The default proc setting will not allow large datasets.

You may want to read up on 'man sysconfig'
and notably 'man sys_attrs_proc' this will tell you which (few) params can be changed without reboot.

Also, be sure to check ulimit -a
You might still have just a soft limit.


>> When run on our test server it runs successfully. The server is exactly the same except it has a total of 4Gb memory.

You primary concern here is virtual memory settings, not physical memory.

Lack of virtual memory will cause errors are reported. Lack of physical memory will 'only' slow you down.

Finally, please be sure to check up on the installation guide / release notes / readme for the application used. It will contain the minimum settings. That should be enough to break through the red tape (basically someone messed up the original install!)
As you appear to be using Oracle, jus thit the web, even this itrc. There are 'tons' of 'best practice', 'install walkthrough' and so on available for Oracle on Tru64.

Enjoy!
Hein.






Joan Shannon
Occasional Visitor

Re: Heap Space error

Thanks for your responses. We've got the sysconfig changes going in on Saturday - will let you know the outcome on Monday (and be able to give points then too.)
Joan Shannon
Occasional Visitor

Re: Heap Space error

We finally got the changes in yesterday and its worked successfully. I'm not convinced we've changed them to the right settings, but its working which is the main thing and gives me some time to read up on what they should be.

Thanks to all of you for your help! This is a great site - have even passed it over to our HP team who support our servers!