cancel
Showing results for 
Search instead for 
Did you mean: 

High memoru consumption

medstn
Occasional Visitor

High memoru consumption


hello:
OS:HP-UX B.11.11
Memory: 32GB
Oracle Application Server 9.0.1.4.0

Sometimes we noticed low applications performance: the free memory then is about 600MB and the system is highly swapping.

we found that strange since we have about only 500 connected users.

I'm asking if anyone has faced such situation with OAS9.0.4 installed on HP-UX B.11.11.
5 REPLIES
Manix
Honored Contributor

Re: High memoru consumption

Please send swapinfo -tam to check reserver
swap space.
& do check "shmmax" tuned by you as per the requirement & SGA of data base.

Some tunables for better performance of Data
bases ,shmmax is the primary one.

shmmax - The maximum size(in bytes) of a single shared memory segment.
shmmin - The minimum size(in bytes) of a single shared memory segment.
shmmni - The number of shared memory identifiers.
shmseg - The maximum number of shared memory segments that can be attached by a process.
semmns - The number of semaphores in the system.
semmni - The number of semaphore set identifiers in the system; determines the number of semaphore sets that can be created at any one time.
semmsl - The maximum number of sempahores that can be in one semaphore set. It should be same size as maximum number of Oracle processes.
HP-UX been always lovable - Mani Kalra
Alzhy
Honored Contributor

Re: High memoru consumption

Set your bufpages (buffer cache) to around 2GB (but monitor that sar -b read from cache %pctg does not consistently go below 90%).



You have a DB with this OAS installation too right? Or is the DB hosted elsewhere?

If DB is on this server, and the datafiles are stored on mount points (filesystems) -- then check if the mount directive is set to forcedirectio,convosync as the recipe for 11.11 based DBs on Cooked filesystems is to have a meagre buffer cache and direct Oracle to use directIO (bypass the buffer cache by the OS)

Is this a new environment or been runnng for ages?


HTH.

Hakuna Matata.
Jose Mosquera
Honored Contributor

Re: High memoru consumption

Hi,

Please check "dbc_max_pct" Kernel value.

It determines the *percentage* of main memory to which the dynamic file system buffer cache is allowed to grow. The default is 50 percent of memory, but this is major overkill in most cases. With a huge buffer cache, you are more likely to get into a situation where free memory is low and you will need to pageout or shrink the buffer cache in order to meet memory demands for active processes. If you want to use a dynamic buffer cache, start with dbc_max_pct at a value equivalent to 1Gb. In your case with 32GB of memory, set dbc_max_pct between 3 or 4 to ensure a 1GB limit. The real value should be 3,13 but this non an integer value.

By the way, on 11i this tuning requires reboot (please check it).

Rgds.
Emil Velez
Honored Contributor

Re: High memoru consumption

DBC max is probably set to 50%

this means any memory not used by processes will be used by buffer cache.

Set this parameter lower so you have some unused memory and buffer cache doesnt grow too big.
INH
Regular Advisor

Re: High memoru consumption

Hello,

I would check shmmax paramter and swap utilisation and size of current swap.

<< 32gb="">So shmmax should be set to to atleast to 16GB ( as per my understanding & as recemended)

check swap memory. if it requires to be increased

this should give some improvement on the issue

Regds,
INH
Knowledge is power