System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

How to change from nolargefile to largefiles in filesystem

baong
Frequent Advisor

How to change from nolargefile to largefiles in filesystem

Hi all,
I like to change my file system from nolargefile to largefiles, i dont have online JFS

what i did is
1) umount /dbfile/sybase/data
2) edit fstab change nolargefile to largefiles
3) mount -F vxfs -o largefiles /dev/vg01/lv02 /dbfile/sybase/data

i got error message
"UX:vxfs mount: ERROR: V-3-21272: mount option(s) incompatible with file system /dev/vg01/lv02"

Any input will appreaciate..
Thanks all
9 REPLIES
Patrick Wallek
Honored Contributor

Re: How to change from nolargefile to largefiles in filesystem

You also need to actually change the file system.

I would modify /etc/fstab and remove the 'largefiles' option. That way it will mount with whatever option is there. Then remount the file system.

Now try changing with 'fsadm'. I don't remember if this requires online JFS or not.

# fsadm -o largefiles /dbfile/sybase/data

Check the status of the change by:

# fsadm /dbfile/sybase/data
Steven E. Protter
Exalted Contributor

Re: How to change from nolargefile to largefiles in filesystem

Shalom,

fsadm will let you maeke the change.

largfiles has not been supported as an /etc/fstab mount option since 11.11 HP-UX 11iv1

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Pete Randall
Outstanding Contributor

Re: How to change from nolargefile to largefiles in filesystem

And, no it does not require online JFS.


Pete

Pete
Matti_Kurkela
Honored Contributor

Re: How to change from nolargefile to largefiles in filesystem

The fstab/mount command option "largefiles" is a check only: "this filesystem must be configured with the largefiles option, don't mount if it isn't."

Even though you don't have OnlineJFS, you should still have the fsadm command (although with reduced functionality).

When the filesystem is unmounted, you can modify the actual state of the largefiles flag with:

fsadm -F vxfs -o largefiles /dev/vg01/lv02

MK
MK
James R. Ferguson
Acclaimed Contributor

Re: How to change from nolargefile to largefiles in filesystem

Hi:

> SEP: largfiles has not been supported as an /etc/fstab mount option since 11.11 HP-UX 11iv1

Not true. Using 'largefiles' or 'nolargefiles' in '/etc/fstab' simply enforces a match with the actual filesystem setting at the time of a mount. You don't need the option since it's the filesystem metadata largefiles bit that determines the case.

Regards!

...JRF...
baong
Frequent Advisor

Re: How to change from nolargefile to largefiles in filesystem

here is the output i got
# /usr/sbin/fsadm -F vxfs -o largefiles /dev/vg01/lv02
UX:vxfs fsadm: ERROR: V-3-20279: /dev/vg01/lv02 is not the root inode of a vxfs file system
# uname -a
HP-UX delaware B.11.23 U ia64 0911252246 unlimited-user license
Patrick Wallek
Honored Contributor

Re: How to change from nolargefile to largefiles in filesystem

Is the file system mounted? If so, do:

fsadm -F vxfs -o largefiles /dbfile/sybase/data

If it is not mounted, mount it then run the above command.
Pete Randall
Outstanding Contributor

Re: How to change from nolargefile to largefiles in filesystem

Use the raw device:

/usr/sbin/fsadm -F vxfs -o largefiles /dev/vg01/rlv02


Pete

Pete
baong
Frequent Advisor

Re: How to change from nolargefile to largefiles in filesystem

Pete,
I ran command
/usr/sbin/fsadm -F vxfs -o largefiles /dev/vg01/rlv02

and mount back everything working now.
Thanks alot all