System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

How to install and configure openssh

SOLVED
Go to solution
raiden
Regular Advisor

How to install and configure openssh

Please tell me the link or steps to install and configure openssh 4.3p2 on HP-UX 11i as there is no depot file in the dwnled install file. I have searched on the openssh.org but couldnt find Installation steps.
20 REPLIES
Torsten.
Acclaimed Contributor

Re: How to install and configure openssh

See

http://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=T1471AA

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Steven E. Protter
Exalted Contributor

Re: How to install and configure openssh

Shalom,

You download the link above. I normally use a browser based on an hpux server to avoid a problem with ftp ascii/binary issues.

Put the depot in /tmp say.

swinstall -s /tmp/depotname \*

That installs it.

Configuration at that point is standard from the http://www.openssl.org website.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Torsten.
Acclaimed Contributor

Re: How to install and configure openssh

The installation procedure is linked on the page above:

http://h20392.www2.hp.com/portal/swdepot/displayInstallInfo.do?productNumber=T1471AA

more here:

http://docs.hp.com/en/internet.html#HP-UX%20Secure%20Shell

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
raiden
Regular Advisor

Re: How to install and configure openssh

Torsten , Steven -- Thanks for the replies.... I have HP ssh already installed but I want open ssh . This is regarding RSA SecurID testing. The RSA SecurID doesnt support HP ssh . So i want compiling steps for OPen SSH . Please guide me with the compilation steps
Torsten.
Acclaimed Contributor
Solution

Re: How to install and configure openssh

The HP version is based on openssh, but anyway, try this:

http://hpux.asknet.de/hppd/hpux/Networking/Admin/openssh-5.1p1/

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Steven E. Protter
Exalted Contributor

Re: How to install and configure openssh

Whoops on my post:
http://docs.hp.com/en/5991-7517/ch01s04.html

openssh, not openssl.

There are a lot of good tips at http://www.openssh.org

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
raiden
Regular Advisor

Re: How to install and configure openssh

Hey Torsten , that was really good info. 10 points for that but please help me to find similar depot for OpenSSH 4.3p2 or 4.5p1 . I really need these 2 depots since only these two are supported for RSA SecurID .
Steven E. Protter
Exalted Contributor

Re: How to install and configure openssh

Sorry, you can't choose the depot from http://software.hp.com

If you need a specific version of openssh, you can get it from http://www.openssh.org . I do not recommend this.

IF you need a specific version of openssh from HP and have a software contract you can arrange for ftp access to prior versions.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
raiden
Regular Advisor

Re: How to install and configure openssh

yes Steven, even I would also not go for the tar file provided by openssh.org because I dont understabd the compilation steps of that software. So i am looking for a ready made depot of openssh .

By your second comment , do u mean that if I have a software contract with HP I can request for a precompiled Openssh depot from HP support. Please suggest.
Steven Schweda
Honored Contributor

Re: How to install and configure openssh

> [...] I dont understabd the compilation
> steps of that software.

ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/INSTALL

[...]
2. Building / Installation
--------------------------

To install OpenSSH with default options:

./configure
make
make install
[...]


There are some prerequisites, but nothing
very complex.

Why do you want this particular (old) SSH
version?
OldSchool
Honored Contributor

Re: How to install and configure openssh

"depot for OpenSSH 4.3p2 or 4.5p1.....only these two are supported for RSA SecurID."

Where did *that* come from. I see no reference to in on the SecurID pages...but I could have missed something.

I would check again with your vendor. Openssh5.1 or 5.1p1 *ought* to work as well, as they are newer. In which case, you can use the depot named above.
Steven E. Protter
Exalted Contributor

Re: How to install and configure openssh

You ask:

By your second comment , do u mean that if I have a software contract with HP I can request for a precompiled Openssh depot from HP support. Please suggest.

IF you have a software contract and ask nicely, HP may make the deptot/pre-compiled version of openssh available to you. If the version you want is buggy or has serious security flaws they may say no.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
raiden
Regular Advisor

Re: How to install and configure openssh

@ Steven Protter -- Thanks Steven . I will log a call with HP and check with them.

@ Old School--- I had logged a call with RSA SecurID helpdesk and they replied that 4.3p2 is supported on PA -RISC 32 bit system and 4.5p1 is supported on IA 64 bit system . They haven't mentioned any support for higher version of Open SSH . So I will also check with them .

@ Steven Schweda ---- I had already checked that ftp link before but there are no files on that link .. If you can view the installation procedure can you post it here as an attachment
Steven Schweda
Honored Contributor

Re: How to install and configure openssh

> [...] there are no files on that link [...]

What does that mean? This link works fine
for me:

ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/INSTALL
raiden
Regular Advisor

Re: How to install and configure openssh

yes Steven I dont see anything on that link. Please someone attach the instructions if you are able to see them
Dennis Handly
Acclaimed Contributor

Re: How to install and configure openssh

>I don't see anything on that link.

I have no problems in IE or firefox and also the directory works fine:
ftp://ftp.ca.openbsd.org/pub/OpenBSD/OpenSSH/portable/
raiden
Regular Advisor

Re: How to install and configure openssh

I am in India and this link is not opening from here. I simply dont understand... Guys please attach the installation instruction if any over there.
OldSchool
Honored Contributor

Re: How to install and configure openssh

"..RSA SecurID helpdesk and they replied that 4.3p2 is supported on PA -RISC 32 bit system and 4.5p1 is supported on IA 64 bit system.."

I believe you are reading too much into the "helpdesk" reply. Those are the "old" versions...and HP might have supplied them in the past. (I currently have 4.3p2 installed on an old 11.0 box). I think they where trying to tell you what HP supported (or supplied).

Instead ask them is they work with . I'll bet the answer is yes. I seriously doubt that versions are not "backward" compatible.
Jeff_Traigle
Honored Contributor

Re: How to install and configure openssh

You can use HP's Secure Shell with RSA SecurID provided the following two criteria are met:

1. You must use PAM authentication.

and

2. You must get non-pthreaded version from HP. (The version available from http://software.hp.com/ is pthreaded.)

We're doing this on our 11.23 and 11.31 systems with HP-UX Secure Shell 5.0 and contemplating retrofitting our 11.11 systems so we can get away from our older compiled version of OpenSSH and standardize on one configuration across the board.
--
Jeff Traigle
raiden
Regular Advisor

Re: How to install and configure openssh

Jeff,


Where can I get this non pthreaded version . Is HP Secure shell 05.10.006 a non Pthreaded version.