cancel
Showing results for 
Search instead for 
Did you mean: 

ILO2 virtual serial port

SOLVED
Go to solution
Joe_P
Frequent Advisor

ILO2 virtual serial port

Hi all,

I tried the following to enable the Virtual Serial Port on ILO2 on a Rx2620 running Redhat AS 4.4

1) add line append="console=ttyS0 rhgb quiet root=LABEL=/" to elilo.conf

2) add line s0:2345:respawn:/sbin/agetty 115200 ttyS0 vt100 to /etc/inittab

3) add ttyS0 to /etc/securetty

4) reboot server

But we get no login or console output on the Virtual Serial Port 'Live Console' except message
'....Loading initrd initrd-2.6.9-42.EL.img...done'

Is there anything else which needs to be done?

Thanks,
Martijn.
3 REPLIES
smatador
Honored Contributor

Re: ILO2 virtual serial port

Hi,
Do you have read the howto for vsp
http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00263709/c00263709.pdf
comment the splashimage
Hope it helps
Matti_Kurkela
Honored Contributor
Solution

Re: ILO2 virtual serial port

The procedure you're following is apparently the one intended for Proliant servers, and may require some modifications for Itanium hardware.

The bootloader's last message is visible, so the EFI has apparently been configured to use the correct serial device.

After that point, any messages are produced by the kernel, which may or may not identify the Virtual Serial Port as ttyS0.

When using a serial console, you could remove the "rhgb" option because it is meaningless on a serial console.

Linux is supposed to be able to get the choice of the console device from EFI automatically, so adding the "console=ttyS0" option might just be confusing things.

Start by identifying the serial devices detected in your system:

setserial -g /dev/tty*
(this may produce quite a lot of "Cannot get serial info: Invalid argument" error messages, but it will also list all the serial port devices.)

You could then create agetty lines for all detected serial ports in your inittab, i.e.:

s1:2345:respawn:/sbin/agetty 115200 ttyS1 vt100
s2:2345:respawn:/sbin/agetty 115200 ttyS2 vt100
etc...

After editing /etc/inittab, run "telinit q" to make the changes take effect immediately.

Now try accessing the Virtual Serial Port again. You may need to press Enter a few times after connecting to see the login prompt. Login as a regular user (not as root) and use the command "tty". It will report which of the tty devices is being used by your session.

Now you know the correct ttyS* name, so edit the lines in elilo.conf and /etc/securetty to match that.

MK
MK
Joe_P
Frequent Advisor

Re: ILO2 virtual serial port

Matti, thanks a lot!

Works like a charm now (turned out it was ttyS3)