System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

INIT: id "x" respawning too fast:disabled for 5 mintues

 
SOLVED
Go to solution
ganesh pink
Occasional Contributor

INIT: id "x" respawning too fast:disabled for 5 mintues

I am using RHEL5 when i boot the linux it directly go to runlevel 3 while i am trying to graphics mode using init 5 its show errror msg like this
INIT: id "x" respawning too fast:disabled for 5 mintues
5 REPLIES
Andras Ordogh
Valued Contributor

Re: INIT: id "x" respawning too fast:disabled for 5 mintues

hello,

maybe you have to check:
- all necesarry x packet installed?
- all installation finished without error?
- try to reconfigure X
- logs?

andras
Alex Glennie
Honored Contributor

Re: INIT: id "x" respawning too fast:disabled for 5 mintues

~sesh
Esteemed Contributor

Re: INIT: id "x" respawning too fast:disabled for 5 mintues

May be Xorg is not configured correctly. Try:
X -configure

Or check the /etc/X11/xorg.conf file for any entries that are not relevant to your system, or any missing ones.

Also, as already suggested may be you have not installed all packages required for graphical desktop.
pradeep m
Respected Contributor
Solution

Re: INIT: id "x" respawning too fast:disabled for 5 mintues

You probably set wrong parameters for your video card or monitor. If you receive a log-in prompt after the error message, simply log-in as root, and type "xf86config". Make sure you have all the specs for your monitor and graphics card available. Always test the settings if asked. If it wont test properly then go back and redo some settings. You can also log-in to a console at boot by typing "linux init 3" (without the quotes of course).
If asked to startx at reboot say yes. When you redo the settings and reboot, if you do not get a graphical login, just type startx and that will bring you to kde. I would set resolution at 1024 / 768 and color to 256 for sure to get going. Go here for more info.

You may also experience this issue due to incorrect /etc/inittab file. refer the below link for details
http://www.unixguide.net/linux/faq/09.24.shtml

Hope it helps!
Regards,
Pradeep

I am an HP Employee
A quick resolution to technical issues for your HP Enterprise products is just a click away HP Support Center Knowledge-base
See Self Help Post for more details


ganesh pink
Occasional Contributor

Re: INIT: id "x" respawning too fast:disabled for 5 mintues

thank you all. found some incorrect entries in the inittab file. restored it and fixed the issue.