System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Install library c-isam at hp-ux 11.31 (itanium)

 
SOLVED
Go to solution
yulianto piyut
Valued Contributor

Install library c-isam at hp-ux 11.31 (itanium)

hi all,

how can I get c-isam library on hp-ux 11.31 run on itanium server ?


-yut-
12 REPLIES
Matti_Kurkela
Honored Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

You mean Informix C-ISAM?

Ask IBM. They supply the product, so they should be able to offer support for it too.

http://www-01.ibm.com/software/data/informix/cisam/

In general, all HP-UX Itanium servers include the Aries emulator, which can run PA-RISC HP-UX binaries on Itanium. Of course, if you can get native Itanium versions, it will run faster. And you cannot use a PA-RISC library with a native Itanium program or vice versa.

MK
MK
yulianto piyut
Valued Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

hi,

thx for your answer. My application admin need c-isam library, in the other server that run on PARISC platform, they use it. I have already copy these libraro to itanium server, but application admin told me that still failed. hmmm...
VK2COT
Honored Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

Hello,

Vendor (IBM) must provide support
for the product. If they do not, then you
are simply not getting value for your money,

Here are the IBM Informix releases
supported on HP-UX servers:

http://www-01.ibm.com/software/info/integrity/index.jsp

Informix C-ISAM 7.25.UC2 is listed as
supported version.

On the other hand, HP ISV page shows version
7.26.UC3 as supported:

https://h20299.www2.hp.com/CustomerTool/isv_status.aspx?st=anltr&qry=i

Make sure you follow the vendor's
installation requirements!

Also, you did not specify what kind of
errors you are getting. It is difficult
to answer the incomplete question.

Cheers,

VK2COT
VK2COT - Dusan Baljevic
yulianto piyut
Valued Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

hi,

we have no deal with IBM so we don't have support from them.
i just copy this library from my system run hp-ux 11.11 to new system run hp-ux 11.31, and got this error (got from application team)

/usr/include/isam.h:44:21: error: decimal.h: No such file or directory
Dennis Handly
Acclaimed Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

>/usr/include/isam.h:44:21: error: decimal.h: No such file or directory

It appears you also need to copy decimal.h, etc.
yulianto piyut
Valued Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

how about these errors:

smdapp@smedpapp4:~
501 #> gcc teskus.c -o tes -lisam
ld: Mismatched ABI (not an ELF file) for -lisam, found /usr/local/lib/gcc/ia64-hp-hpux11.31/4.2.3/../../../libisam.a
Fatal error.
collect2: ld returned 1 exit status

Dennis Handly
Acclaimed Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

>how about these errors:
>/usr/local/lib/gcc/ia64-hp-hpux11.31/4.2.3/../../../libisam.a

This is says you have a PA32 lib, not an IPF library.
yulianto piyut
Valued Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

"This is says you have a PA32 lib, not an IPF library."
what does it mean? what should i do ?
Dennis Handly
Acclaimed Contributor
Solution

Re: Install library c-isam at hp-ux 11.31 (itanium)

>what does it mean? what should I do?

You are trying to mix a PA library with an Integrity application.

You could purchase or build your own Integrity version of c-isam.

Or you will have to build your application on a PA system (or use XPADE) and run it under Aries on your Integrity system.
yulianto piyut
Valued Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

hi dennis, thx for your answer.
file is PA executable. I don't understand about using ARIES. how to run this script (teskus.c) in integrity system ?

# gdb /home/smdapp/teskus.c
Detected PA executable.
Invoking /usr/ccs/bin/gdbpa.
HP gdb 5.9 for PA-RISC 1.1 or 2.0 (narrow), HP-UX 11.00
and target hppa1.1-hp-hpux11.00.
Copyright 1986 - 2001 Free Software Foundation, Inc.
Hewlett-Packard Wildebeest 5.9 (based on GDB) is covered by the
GNU General Public License. Type "show copying" to see the conditions to
change it and/or distribute copies. Type "show warranty" for warranty/support.
.."/home/smdapp/teskus.c": not in executable format: File format not recognized

yulianto piyut
Valued Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

# more /home/smdapp/teskus.c
#include
#include "/usr/local/include/isam.h"

main (argc, argv)
int argc;
char *argv[];
{
printf("tes\n");
int fi;
fi = isopen("/opt/home/mdsamd/amd/arm/local/bin/list_lac+ci", ISINOUT+ISMANULOCK);
}
Dennis Handly
Acclaimed Contributor

Re: Install library c-isam at hp-ux 11.31 (itanium)

>file is PA executable.

I don't see any here?
But the above one where you compiled with gcc from source isn't.

>I don't understand about using ARIES.

Aries is what's used automatically when you run a PA executable.

>how to run this script (teskus.c) in Integrity system?
># gdb /home/smdapp/teskus.c
>"/home/smdapp/teskus.c": not in executable format: File format not recognized

This is a C source file. If you compile on Integrity, you need an Integrity version of libisam.a.

If you don't have one, you will have to build it on your PA system and then run the PA executable on Integrity.