HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Installation fails with Java6

 
Vaudeville_Villain
Occasional Visitor

Installation fails with Java6

I have tried to install an application using Java6 and received following error:

/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'JudySLIns' in load module '/tmp/ismp029/libhpuxppk.1'

Installation works ok with Java 1.5.

What's wrong with Java6?

Thank you in advance.
7 REPLIES
Jupinder Bedi
Respected Contributor

Re: Installation fails with Java6

please find the following linl , may be helpful for you


http://docs.hp.com/en/JDKJRE60RN/jdk_rnotes_6.0.00.html
All things excellent are as difficult as they are rare
Vaudeville_Villain
Occasional Visitor

Re: Installation fails with Java6

Thank you very much for your answer. Unfortunately I'm not a big pro with Java thingies. Could you please just let me know what is wrong?

God bless you.
Jupinder Bedi
Respected Contributor

Re: Installation fails with Java6

*** REQUIRED JAVA 6.0 PATCHES ***

Some patches are required for JDK and JRE 6.0.00. First, the Java 5.0 Quality Pack patches must be installed. Refer to Patch Information and follow the Java 5.0 recommendations.

Second, a linker patch is also required. The patch id is PHSS_35385 for 11.11 systems, PHSS_37201 for 11.23 systems, and PHSS_37202 for 11.31 systems. This patch fixes a problem loading libjli.sl.

*** IMPORTANT NOTE FOR JAVA 6.0 setuid/setgid USERS! ***

If you use setuid/setgid, you will need to install patches and set up /etc/dld.sl.com to run your application. More details can be found in the Running Java with setuid or setgid on HP Integrity and PA-RISC section.

*** IMPORTANT NOTE FOR PA-RISC CUSTOMERS ON HP-UX 11i v1 (11.11)! ***

Patch PHNE_35183 (or its superseding patch) must be installed for HP-UX 11i v1 (11.11) PA-RISC; this patch solves socket problems that may cause hangs. Additionally, pthreads patch PHCO_36229 (or its superseding patch) must also be installed. These patches are not required for Integrity systems or PA-RISC systems running HP-UX 11.23 or 11.31. To determine whether these patches have been installed on your machine, log in as root and check your machine with:

/usr/sbin/swlist -l product

The required patches change frequently and may include patches other than those listed in these release notes. To ensure that you have installed all of the required and recommended patches needed, visit the Java Required Patches web page at Patch Information.

HP-UX system requirements

HP Integrity servers: Integrity servers running HP-UX 11i v2 or v3 (11.23 or 11.31) are supported. Refer to the following website for more information about HP Integrity servers: HP Integrity Servers.

HP PA-RISC 9000 systems: Java 6.0 is supported on all PA-RISC 2.0 machines running HP-UX 11i v1 (11.11), 11i v2 (11.23), or 11i v3 (11.31).

Web browser requirements

The only web browser supported for the Java 6.0 Plug-in is Mozilla/Firefox for HP-UX version 1.5.0.00 or later. Netscape is not supported.

Please see if anything is missing
All things excellent are as difficult as they are rare
Vaudeville_Villain
Occasional Visitor

Re: Installation fails with Java6

Linker patch is installed:

/usr/sbin/swlist -l product | grep 37201
PHSS_37201 1.0 linker + fdp cumulative patch

I have HPUX 11.23 IA64, so I guess that's all.

I have been told that HP JRE packs libraries for PA-RISC and IA both, so if user decides to use their own jre then they will have to specify their library path via LD_LIBRARY_PATH.

But I have no idea what path should be set exactly.

On the other hand, the installer works ok with Java 1.5 without any SHLIB_PATH or LD_LIBRARY_PATH set.

Re: Installation fails with Java6

>dld.so: Unsatisfied code symbol 'JudySLIns' in load module '/tmp/ismp029/libhpuxppk.1'

This indicates you don't have Judy installed or it isn't linking against that shlib.

>Installation works ok with Java 1.5. What's wrong with Java6?

I'm not sure why it would make a difference. Which product contains libhpuxppk.1? (BBJ from Basis that runs an InstallShield Wizard?) This appears to be a non-HP product that seems to be used only when java6 is used and java6 gets the blame?

There is another thread with a similar problem:
http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1314554
(I'm not sure there ever was a solution?)

What does this show:
swlist Judy

You can download Judy here:
https://h20392.www2.hp.com/portal/swdepot/searchProducts.do

>Jupinder: please find the following link

I see nothing there about Judy.

Vaudeville_Villain
Occasional Visitor

Re: Installation fails with Java6

Thank you for your patience.

Judy is installed:

# Judy B.11.23.04.17 Judy Library and Related files
Judy.Judy-lib B.11.23.04.17 Judy Library and Related files

What can be the reason of inability to link it?

Re: Installation fails with Java6

>What can be the reason of inability to link it?

They forgot? Or they wanted it to work for java1.5??
Who is they here? This seems like that other thread I mentioned.