System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing wireshark on hpux 11..11

Ivan Azuara
Regular Advisor

Installing wireshark on hpux 11..11

Hi,

Could you help me to fix the next dependencies into my wireshark installation on hpux 11.11:

Reading source for product information.
* Reading source for file information.
The corequisite "atk.atk-RUN" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "cairo.cairo-RUN" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "fontconfig.fontconfig-RUN" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "freetype.freetype-RUN" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "gettext.gettext-SHLIBS" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "glib2.glib2-SHLIBS" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "gnutls.gnutls-SHLIBS" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
* To be complete, the dependent software
"gtk+2,l=/usr/local,r=2.20.1" needs the following filesets:
* gtk+2-RUN
* gtk+2-SHLIBS
The corequisite "gtk+2" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "heimdal.heimdal-SHLIBS" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "openssl.openssl-SHLIBS" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
The corequisite "pango.pango-SHLIBS" for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be successfully
resolved.
ERROR: The dependencies for fileset
"wireshark.wireshark-RUN,r=1.2.10" cannot be resolved (see
previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
The corequisite "gettext.gettext-SHLIBS" for fileset
"wireshark.wireshark-SHLIBS,r=1.2.10" cannot be successfully
resolved.
The corequisite "glib2.glib2-SHLIBS" for fileset
"wireshark.wireshark-SHLIBS,r=1.2.10" cannot be successfully
resolved.
The corequisite "gnutls.gnutls-SHLIBS" for fileset
"wireshark.wireshark-SHLIBS,r=1.2.10" cannot be successfully
resolved.
The corequisite "heimdal.heimdal-SHLIBS" for fileset
"wireshark.wireshark-SHLIBS,r=1.2.10" cannot be successfully
resolved.
The corequisite "openssl.openssl-SHLIBS" for fileset
"wireshark.wireshark-SHLIBS,r=1.2.10" cannot be successfully
resolved.
ERROR: The dependencies for fileset
"wireshark.wireshark-SHLIBS,r=1.2.10" cannot be resolved (see
previous lines).
You must resolve the above dependencies before operating on
this fileset or change the "enforce_dependencies" option to
"false".
* Executing preDSA command.
NOTE: The used disk space on filesystem "/usr" is estimated to
increase by 8096 Kbytes.
This will leave 980576 Kbytes of available user disk space
after the installation.
NOTE: The used disk space on filesystem "/var" is estimated to
increase by 16 Kbytes.
This will leave 3260024 Kbytes of available user disk space
after the installation.

* Summary of Analysis Phase:
ERROR: Exclude wireshark.wireshark-RUN,r=1.2.10
ERROR: Exclude wireshark.wireshark-SHLIBS,r=1.2.10
ERROR: 2 of 3 filesets had Errors.
* 1 of 3 filesets had no Errors or Warnings.
ERROR: The Analysis Phase had errors. See the above output for
details.



Regards !!
"Enjoy the life .."
6 REPLIES
Dennis Handly
Acclaimed Contributor

Re: Installing wireshark on hpux 11..11

It appears you need to install a whole bunch of products and their dependencies to install wireshark.

You should use swcopy to copy all of the products (wireshark, atk, cairo, fontconfig, freetype, gettext, glib2, gnutls, etc) into one large depot.
swcopy -x enforce_dependencies=false -s $PWD/depot1 \* @ $PWD/big.depot
Ivan Azuara
Regular Advisor

Re: Installing wireshark on hpux 11..11

yep, i did it!!.

swlist output:

atk 1.30.0 atk
bison 2.4.1 bison
bzip2 1.0.5 bzip2
cairo 1.10.0 cairo
db 5.0.26 db
editline 2.9 editline
expat 2.0.1 expat
flex 2.5.35 flex
fontconfig 2.8.0 fontconfig
freetype 2.4.2 freetype
gdbm 1.8.3 gdbm
gettext 0.18.1.1 gettext
glib2 2.24.2 glib2
gnutls 2.10.1 gnutls
gtk+2 2.20.1 gtk+2
heimdal 1.0.2 heimdal
jasper 1.900.1 jasper
jpeg 6b jpeg
libXft 2.1.14 libXft
libXrender 0.9.6 libXrender
libgcrypt 1.4.6 libgcrypt
libgpg_error 1.9 libgpg_error
libiconv 1.13.1 libiconv
libpcap 1.1.1 libpcap
libpng 1.4.3 libpng
lzo 2.03 lzo
m4 1.4.15 m4
make 3.82 make
openssl 1.0.0a openssl
pango 1.28.1 pango
pcre 8.10 pcre
perl 5.10.1 perl
pixman 0.19.2 pixman
readline 6.1.002 readline
renderproto 0.11 renderproto
sudo 1.6.8p12 sudo
tcpdump 4.1.1 tcpdump
termcap 1.3.1 termcap
tiff 3.9.4 tiff
unzip 6.0 unzip
zlib 1.2.5 zlib

The problem is with the shlibs dependencies of each fileset required by wireshark...
"Enjoy the life .."
Dennis Handly
Acclaimed Contributor

Re: Installing wireshark on hpux 11..11

>The problem is with the shlibs dependencies of each fileset required by wireshark.

Is this something you solved or is it still a problem? You should be able to put those dependencies into big.depot too.
James R. Ferguson
Acclaimed Contributor

Re: Installing wireshark on hpux 11..11

Hi Ivan:

If you obtained your source from the HP-UX Porting Centre there is now a 'depothelper' script to download and install a package and all of its dependencies.

http://hpux.connect.org.uk/hppd/hpux/Sysadmin/depothelper-2.00/

Regards!

...JRF...
Ivan Azuara
Regular Advisor

Re: Installing wireshark on hpux 11..11

Hi James, good news !. Let me try !!

Regards !!
"Enjoy the life .."
Ivan Azuara
Regular Advisor

Re: Installing wireshark on hpux 11..11

I'm going to install the last version of wireshark.

Regards !!
"Enjoy the life .."