System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Interpreter "bin/ksh" not found

SOLVED
Go to solution
H_16
Trusted Contributor

Interpreter "bin/ksh" not found

When trying to run create_deport script receiving the following error.

# ./create_depot_hpux.11.23
interpreter "/bin/ksh" not found
file link resolves to "/usr/bin/ksh"
sh: ./create_depot_hpux.11.23: not found.

I have changed the script to /usr/bin/ksh

I then get:

# ./create_depot_hpux.11.23
interpreter "/usr/bin/ksh" not found
sh: ./create_depot_hpux.11.23: not found.
4 REPLIES
James R. Ferguson
Acclaimed Contributor
Solution

Re: Interpreter "bin/ksh" not found

Hi:

You FTP's the script and added carriage-returns to the lines. Either transfer the file correctly or strip the carriage returns:

# dos2ux ./create_depot_hpux.11.23 > ./create_depot_hpux.11.23.new

# mv ./create_depot_hpux.11.23.new ./create_depot_hpux.11.23

Regards!

...JRF...
Steven E. Protter
Exalted Contributor

Re: Interpreter "bin/ksh" not found

Shalom,

You could also simply do the ftp upload again.

If the original file is still around.

I find on systems with ftp access permitted, that using the ftp script option for getting patches avoids all these issues.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
H_16
Trusted Contributor

Re: Interpreter "bin/ksh" not found


Im having problems with my ftp running slow even for very small files...what could this be down to?
James R. Ferguson
Acclaimed Contributor

Re: Interpreter "bin/ksh" not found

Hi (again):

> Im having problems with my ftp running slow even for very small files...what could this be down to?

That's a different issue than the one you opened this thread with. That said, however, the first thing you may want to check is a network duplex mismatch.

If you are running a GB connection, your switch and your LAN card should be set to auto-negotiate.

If you are running an old 100MB connection, you should set your switch and your LAN card to full-duplex, 100MB.

Regards!

...JRF...