HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Iscsi volume session shows online status without mounting.

 
Farooque Sheikh
Occasional Visitor

Iscsi volume session shows online status without mounting.

OS - HP UX 11i V1
Iscsi Software - iSCSI-00_B.11.11.03e_HP-UX_B.11.11_64.depot

Configuration steps done -
1) iscsiutil -t authmethod CHAP (1 way Chap Configured )
2) iscsiutil -a -I 172.31.*.* (Discovered Target)
3) iscsiutil -u -H chap_uni -I 172.31.*.*
4) iscsiutil -u -N abc -I 172.31.*.* (Chap Name)
5) iscsiutil -u -W 1234567890ab -I 172.31.*.* (Initiator Password)
6) ioscan -fnH 255
7) insf -H 255
8) iscsiutil -pS

When I run 8th command volume status (Session state) shows online without mounting.
2 REPLIES
Henry Fauni
Valued Contributor

Re: Iscsi volume session shows online status without mounting.

"Online" Session State is normal. If the sdisk device file is showing "CLAIMED" when you do an ioscan, it will show up as "Online". It's just telling you it completed the login phase and you're now in iSCSI Full feature phase.

It will show "Offline" only if you do an ioscan and the sdisk device file shows "NO_HW". For example, if you physically disconnect storgae device from network or change something with the original "LUN" like unpresent it to this host.

The disk doesn't have to be part of LVM or its filesystem mounted before showing "Online" Session state. If you see the iSCSI disk on ioscan, expect it to be "Online".
Farooque Sheikh
Occasional Visitor

Re: Iscsi volume session shows online status without mounting.

Thanks for reply but I am still confuse bcoz the behaviour is different in none and 1 way chap.
In none scenario,
when I run "ioscan -fnH 255" it find the disk and "iscsiutil -pS" command shows session state as "Online" for few seconds then it gets "Offline". Now when I format the disk and mount it the state changed to "Online" and Unmount the volume it changed to "Offline".
Same has been observed in 1 way chap also but it is not consistent.
Thats the reason I am getting confused.