Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with application

hendrik baars
Occasional Visitor

Issue with application

Hello HP-admins. I encounter a strange problem. We have an application running that shows up a character based menu. However the colours of this menu are apparently changed after the first user started up the application (he is ok the rest is not). After that all other users encounter strange (pink ;-)) colours. The same setup on another box doesnt have the issue. I compared everything and I cant find any difference between the two boxes (shared libraries/binaries/shell settings. Any ideas what might cause this behaviour?
5 REPLIES
Suraj K Sankari
Honored Contributor

Re: Issue with application

Hi,

Did you checked all environment settings.

Suraj
James R. Ferguson
Acclaimed Contributor

Re: Issue with application

Hi:

The 'terminfo' database defines terminal-dependent capabilites.

The $TERM environmental variable should be correctly set so that the proper 'terminfo' applies.

Regards!

...JRF...
Ashish Parashar
Frequent Advisor

Re: Issue with application

Please also check the User's .profile file ...seems some script is present in .profile.

Regards

Ashish
Steven E. Protter
Exalted Contributor

Re: Issue with application

Shalom,

You may also need whats called a termcap file. That is matched to your TERM.

There should be specifications in the application documentation.

To do this an RTFM is required, IMO.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
OldSchool
Honored Contributor

Re: Issue with application

Also, if you're using terminal emulator software, check / compare the settings between working / non-working user(s)