System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

KERBEROS_V4 rejected as an authentication type

 
SOLVED
Go to solution
sysad_boy
Frequent Advisor

KERBEROS_V4 rejected as an authentication type

I am always encountering this kind of error when I'm running my script via ControlM.

How can I get rid of this error message?
6 REPLIES
Matti_Kurkela
Honored Contributor
Solution

Re: KERBEROS_V4 rejected as an authentication type

Either ControlM or your script obviously does something that requires authentication, and it attempts to use KERBEROS_V4.

Without knowing more about your setup, I cannot determine what that might be.

Wild guess: in RHEL 5, rsh, rlogin and ftp clients will attempt first to use Kerberos, then fall back to classic methods. In this case, this is not an error, but an informative message, reminding you that your password will be sent to the server in unencrypted plaintext.

MK
MK
Matti_Kurkela
Honored Contributor

Re: KERBEROS_V4 rejected as an authentication type

Oops, clicked Submit too soon...

To stop your system from trying to use Kerberos, remove /usr/kerberos/bin from your PATH: this directory contains Kerberos versions of ftp,rcp,rlogin,rsh and telnet.

In RHEL5, this can be done by moving the krb5-*.sh and krb5-*.csh files away from /etc/profile.d directory:

mkdir /etc/profile.d/disabled
mv /etc/profile.d/krb5-*sh /etc/profile.d/disabled

This change will take effect at the next user session, so you may have to logout & login, then restart the ControlM agent (if you use one).

MK
MK
sysad_boy
Frequent Advisor

Re: KERBEROS_V4 rejected as an authentication type

error still encountered
Matti_Kurkela
Honored Contributor

Re: KERBEROS_V4 rejected as an authentication type

Please tell us:

- what is the name of your Linux distribution?

- what is the version of your Linux distribution?

- which version of ControlM are you using?

- are you running your script on the host that has the ControlM agent, or is the agent trying to run a script remotely on another host?

- what does your script actually do?

It is very hard to solve your problem by guessing the necessary details.

Hmm... I think some of the ControlM agent processes run from inetd/xinetd, so to make all ControlM processes pick up the new PATH settngs, you may have to restart inetd/xinetd too.

MK
MK
sysad_boy
Frequent Advisor

Re: KERBEROS_V4 rejected as an authentication type

My OS is
Linux Red Hat 5 release 2

My ControlM Version is 6.3.1

I am running my script on the host that has the agent.

sysad_boy
Frequent Advisor

Re: KERBEROS_V4 rejected as an authentication type

do i really need to have xinetd installed?