cancel
Showing results for 
Search instead for 
Did you mean: 

LAN problem

Ron Irving
Trusted Contributor

LAN problem

lanadmin -x 1 shows 100BaseT.

Sam shows lan1 at 1000BaseT

How do I make A=B?
Should have been an astronaut.
52 REPLIES
Pete Randall
Outstanding Contributor

Re: LAN problem

Are you sure they are the same NIC? What does lanscan show?


Pete

Pete
Ron Irving
Trusted Contributor

Re: LAN problem

Same NIC. A7012A
Should have been an astronaut.
Pete Randall
Outstanding Contributor

Re: LAN problem

Sorry, that was probably a pretty silly question.

In order to get 1000BaseT, both ends of the link are supposed to be set to AUTO. Can you verify?


Pete

Pete
Ron Irving
Trusted Contributor

Re: LAN problem

Auto Neg is set to on, on my end. Infrastructure says it's on, on the switch end too.
Should have been an astronaut.
Patrick Wallek
Honored Contributor

Re: LAN problem

Can you please post the full output of your lanadmin command?
Ron Irving
Trusted Contributor

Re: LAN problem

lanadmin -g 1
Should have been an astronaut.
Patrick Wallek
Honored Contributor

Re: LAN problem

Sorry, I meant just the full output of the 'lanadmin -x 1'.

Ron Irving
Trusted Contributor

Re: LAN problem

ah...here you go!
Should have been an astronaut.
Torsten.
Acclaimed Contributor

Re: LAN problem

So the autoneg results in 100 MB/s; the solution must be found at the switch side ... is it autoneg too or a fixed speed?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Ron Irving
Trusted Contributor

Re: LAN problem

According to the network dude, it's set for auto negotiate. If this were the case, then I could not run ladadmin -S 1000000000, correct?
Should have been an astronaut.
Ron Irving
Trusted Contributor

Re: LAN problem

anyone?
Should have been an astronaut.
Ganesan R
Honored Contributor

Re: LAN problem

Hi,

There are few other things you need to check?

Is there any other device which doesnot support autoneg involved in between the switch and lan interface? Like hub or bridge.

Cable also should support 1000Mbps. otherwise you will not get 1000Mbps speed.
Best wishes,

Ganesh.
Ron Irving
Trusted Contributor

Re: LAN problem

Our infrastructure team, and I changed cables, and ports on the switch...same result.
Should have been an astronaut.
Ron Irving
Trusted Contributor

Re: LAN problem

no hub or bridge between either.
Should have been an astronaut.
Robert-Jan Goossens
Honored Contributor

Re: LAN problem

Hi Ron,

Could you post the output of;

# what /stand/vmunix | grep iether

Regards,
Robert-Jan
Ganesan R
Honored Contributor

Re: LAN problem

Hi,

I am still doubting switch side settings. If you are sure that this card is 1000BaseT and autoneg is ON, try to use the port which is working in 1000Mbps in your environment.
Best wishes,

Ganesh.
Ron Irving
Trusted Contributor

Re: LAN problem

Well...my network guy is adament on this issue. He is positive it's at 1000BaseT.

Here's the output of the iether
Should have been an astronaut.
Pete Randall
Outstanding Contributor

Re: LAN problem

I've got a network guy just like him! ;^)

Is there another server with a properly functioning GB NIC? Can you sneak into the switch room and connect this server to the port that is properly functioning? Or can you diplomatically ask him to show you the proof that this port is, indeed, set to auto-negotiate.

If the port is set properly, then the only other cause has to be between the port and the NIC and if there's no other hardware, then it has to be cabling. The next step is swapping out cables.


Pete

Pete
Ron Irving
Trusted Contributor

Re: LAN problem

During the day it would take a Presidential decree, or an amendment to the constitution to move switch ports. Developers and the business community would be outside my door with torches and pitchforks. No sense of humour.

Our next maintenance window is 5/16, so we'll just have to limp along until then, or until I can get a 'special-window'.

I was just seeing if there was anything I could do ahead of that.
Should have been an astronaut.
Shardha
Valued Contributor

Re: LAN problem

Dear,

I belive if you turn off auto negotiation and set it to full duplex FD. This will work perfectly.
Pete Randall
Outstanding Contributor

Re: LAN problem

> I belive if you turn off auto negotiation and set it to full duplex FD. This will work perfectly.

In a work: No.

This is not how GB ether works. It is designed to be set to auto-negotiate. Forcing either end of the connection as suggested is how you end up with a situation like Ron is in.


Pete

Pete
Ganesan R
Honored Contributor

Re: LAN problem

Hi,

Another issue if you set manually will be Duplex mismatching.

Read this about the impact of duplex mismatching...

A duplex mismatch occurs when two connected devices are configured in different duplex modes. This may happen for example if one is configured for autonegotiation while the other one has a fixed mode of operation that is full duplex (no autonegotiation). In such conditions, the autonegotiation device correctly detects the speed of operation, but is unable to correctly detect the duplex mode. As a result, it sets the correct speed but starts using the half duplex mode.

When a device is operating in full duplex while the other one operates in half duplex, the connection works at a very low speed if both devices attempt to send frames at the same time
Best wishes,

Ganesh.
G V R Shankar
Valued Contributor

Re: LAN problem

Hi,

Can you please post the o/p of

ioscan -funC lan
netstat -ni

Ravi.
Ron Irving
Trusted Contributor

Re: LAN problem

Here's the files requested.

Bear in mind, HP APA is installed, and was working fine on our old server. We bought a new one, (rp8420,) and ignited from the old 8420. That's where the lan900 comes in.
Should have been an astronaut.