cancel
Showing results for 
Search instead for 
Did you mean: 

Linux AS4 & EVA 3k

Season Chu
Advisor

Linux AS4 & EVA 3k

Dear All:

I have a Linux AS4 and EVA 3028 firmware.

Using HP EVA System Management Server, Yesterday I assigned a lun to this linux.It's OKAY.

But after a reboot the lun disappear to the system. The following information is that:

[root..]# ./hp_rescan -a
Sending rescan signal to /proc/scsi/qla2xxx/0...
Adding legacy tape devices to /proc/scsi/device_info
Scanning /proc/scsi/qla2xxx/0, target 3, LUN 0

scsi0 00 00 00 HP HSV100 3028 RAID
scsi0 00 00 01 HP HSV100 3028 Direct-Access
scsi0 00 01 00 HP HSV100 3028 RAID
scsi0 00 02 00 HP HSV100 3028 RAID
scsi0 00 03 00 HP HSV100 3028 RAID

[root@hp_fibreutils]# uname -a
Linux EPSVN 2.6.9-78.ELsmp #1 SMP Wed Jul 9 15:39:47 EDT 2008 i686 i686 i386 GNU/Linux

Can someone help me ?
3 REPLIES
Steven E. Protter
Exalted Contributor

Re: Linux AS4 & EVA 3k

Shalom,

Please post:
cat /etc/redhat-release

It would be interesting to see the hp_rescan -a results before lun assignment.

I would go back to the EVA controller and make sure the assignment is still good and includes the correct World Wide Names.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Ivan Ferreira
Honored Contributor

Re: Linux AS4 & EVA 3k

Sometimes you need to install the probe-luns command. See the attached file in the section "Troubleshooting HSV210 devices on Linux" on page 10.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Season Chu
Advisor

Re: Linux AS4 & EVA 3k

Thanks to All.

The problem has been sloved. At first,I try the "hp_rescan -a " to find the luns,but it doesnt work. I have no idea to do it. So I change the lun id on my eva and re-add the host for this lun. Then I execute the "fdisk -l",the lun is appeared. In the end, I vi a script at the "/etc/init.d/" for rescaning the luns when os reboot.

BTW,the thread has been closed.

thanks.