System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Linux LVM2 - Filesystem extension each time needs the server reboot?

 
SOLVED
Go to solution
ALe_3
Frequent Advisor

Linux LVM2 - Filesystem extension each time needs the server reboot?

Dear All,

I am experiencing the following "issue" with Linux LVM2. Actually I have a full installation of RH 5.1 with LVM2 and when I must extend a filesystem I cannot umount the FS.

Even if any user is accessing the FS (I use fuser and lsof to check it),

[root@lxxxx ~]# lsof /tmp
[root@lxxxxx ~]# fuser -u /tmp

when I try to umount it it gives me the error:

[root@lxxxxx ~]# umount /tmp
umount: /tmp: device is busy
umount: /tmp: device is busy

I think that it is the device mapper that locks the FS.

The installation is the default one. I have disabled some services and now the active services are the following:

[root@lxxxxx ~]# chkconfig --list | grep :on
anacron 0:off 1:off 2:on 3:on 4:on 5:on 6:off
atd 0:off 1:off 2:off 3:on 4:on 5:on 6:off
autofs 0:off 1:off 2:off 3:on 4:on 5:on 6:off
cciss_scsi 0:off 1:off 2:on 3:on 4:on 5:on 6:off
cpuspeed 0:off 1:on 2:on 3:on 4:on 5:on 6:off
crond 0:off 1:off 2:on 3:on 4:on 5:on 6:off
cups 0:off 1:off 2:on 3:on 4:on 5:on 6:off
gpm 0:off 1:off 2:on 3:on 4:on 5:on 6:off
haldaemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off
hp-health 0:off 1:off 2:on 3:on 4:on 5:on 6:off
hp-ilo 0:off 1:off 2:on 3:on 4:on 5:on 6:off
hp-snmp-agents 0:off 1:off 2:on 3:on 4:on 5:on 6:off
hpsmhd 0:off 1:off 2:off 3:on 4:on 5:on 6:off
hpvca 0:off 1:off 2:off 3:on 4:on 5:on 6:off
kudzu 0:off 1:off 2:on 3:on 4:on 5:on 6:off
lm_sensors 0:off 1:off 2:on 3:on 4:on 5:on 6:off
lvm2-monitor 0:off 1:on 2:on 3:on 4:on 5:on 6:off
mcstrans 0:off 1:off 2:on 3:on 4:on 5:on 6:off
microcode_ctl 0:off 1:off 2:on 3:on 4:on 5:on 6:off
netfs 0:off 1:off 2:off 3:on 4:on 5:on 6:off
network 0:off 1:off 2:on 3:on 4:on 5:on 6:off
portmap 0:off 1:off 2:off 3:on 4:on 5:on 6:off
readahead_later 0:off 1:off 2:off 3:off 4:off 5:on 6:off
restorecond 0:off 1:off 2:on 3:on 4:on 5:on 6:off
sendmail 0:off 1:off 2:on 3:on 4:on 5:on 6:off
smartd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
smb 0:off 1:off 2:on 3:on 4:on 5:on 6:off
snmpd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
sshd 0:off 1:off 2:on 3:on 4:on 5:on 6:off
syslog 0:off 1:off 2:on 3:on 4:on 5:on 6:off
sysstat 0:off 1:off 2:on 3:on 4:off 5:on 6:off
xfs 0:off 1:off 2:on 3:on 4:on 5:on 6:off
xinetd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

All the kernel modules are loaded:

[root@lxxx ~]# lsmod
Module Size Used by
mptctl 26565 1
mptbase 57569 1 mptctl
sg 35933 0
ipmi_si 41056 2
ipmi_devintf 12808 4
ipmi_msghandler 37184 2 ipmi_si,ipmi_devintf
autofs4 24389 2
hp_ilo 34620 4
ipv6 251393 32
dm_multipath 21577 0
video 19269 0
sbs 18533 0
backlight 10049 0
i2c_ec 9025 1 sbs
i2c_core 23745 1 i2c_ec
button 10705 0
battery 13637 0
asus_acpi 19289 0
ac 9157 0
parport_pc 29157 0
lp 15849 0
parport 37513 2 parport_pc,lp
ide_cd 40033 0
cdrom 36705 1 ide_cd
bnx2 173320 0
serio_raw 10693 0
pcspkr 7105 0
dm_snapshot 20709 0
dm_zero 6209 0
dm_mirror 28741 0
dm_mod 58201 17 dm_multipath,dm_snapshot,dm_zero,dm_mirror
lpfc 282464 6
scsi_transport_fc 37065 1 lpfc
ata_piix 18501 0
libata 115961 1 ata_piix
cciss 67588 5
sd_mod 24897 0
scsi_mod 132685 10 mptctl,sg,lpfc,scsi_transport_fc,libata,cciss,sd_mod
ext3 123337 8
jbd 56553 1 ext3
ehci_hcd 33229 0
ohci_hcd 23389 0
uhci_hcd 25549 0



Is it possible that If I must extend a filesystem I must go to runlevel 1 or reboot the server?

This makes LVM2 not feasible for a production server.

Where do I fail???? Maybe I have missed some configuration or disabled some services that shouldn't be disabled???

Many Thanks in advance

ALe
3 REPLIES
Ralph Grothe
Honored Contributor
Solution

Re: Linux LVM2 - Filesystem extension each time needs the server reboot?

Hi ALe,

on our business Linux boxes we run RHEL 5.[0-2]
and on private boxes usually CentOS 5.2.

There it is absolutely no issue to online resize an FS on an LV, provided you still have any free PEs left in the VG the LV belongs to.

The standard procedure is
e.g.

# lvextend -L +512m /dev/vgroot/lv_var

# resize2fs /dev/vgroot/lv_var

No more than that is required.
The FS like /var may stay mounted with lots of active file accesses, no need to change the runlevel.

Madness, thy name is system administration
ALe_3
Frequent Advisor

Re: Linux LVM2 - Filesystem extension each time needs the server reboot?

Thanks, that's true.

I tried to extend a FS using your instructions and it worked.

The fact is that a colleague told me that I had to umount the FS because in Linux there wasn't the same online option as on HP-UX.

Thanks again.
ALe
ALe_3
Frequent Advisor

Re: Linux LVM2 - Filesystem extension each time needs the server reboot?

Thanks to Ralph