System Administration
cancel
Showing results for 
Search instead for 
Did you mean: 

Linux Red Hat 5.3 (Tikanga) Qlogic Failover - boot from SAN

 
Sebastian Szewczyk
Frequent Advisor

Linux Red Hat 5.3 (Tikanga) Qlogic Failover - boot from SAN

Hello,

I have problem with my Red Hat Linux 5.3 bcause i can't run him in Failover mode.
Disk Arrays is EVA 5000 and EVA 3000 with Active/Passive Firmware.
What can I do when I boot from SAN my Red Hat and I can;t used Failover of my disk from Array.
I try install Qlogic Drivers with option Failover - then i have comunicate Kernel panic after install this driver.
I try Device-mapper-multipath from Red Hat distribution and this not work properly.
Next I try Qlogic Sun Serfer with option Failover dosen't work.
Last time today I try HPDMmultipath-4.1.0-1 and when I install this software I have communicate:
>>"* HPDMmultipath-4.1.0-1 kit Installation. >>Date : Thu Feb 19 15:35:18 CET 2009 **
>>Checking for previous installation. Please >>wait...
>>This version of Enterprise Linux is not >>supported!!!."
Now I read that HPDMmultipath support only Active/Active Firmware.
Please help me what software I can install in tahat situation?

Best regards
seboizm
5 REPLIES
Ivan Ferreira
Honored Contributor

Re: Linux Red Hat 5.3 (Tikanga) Qlogic Failover - boot from SAN

Check the SAN design reference. To boot from SAN, you need VCS 4.X (active/active) firmeware.

http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentType=SupportManual&locale=en_US&docIndexId=179911&taskId=101&prodTypeId=12169&prodSeriesId=406734
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Steven E. Protter
Exalted Contributor

Re: Linux Red Hat 5.3 (Tikanga) Qlogic Failover - boot from SAN

Shalom,

The SAN software you need is not supporting this OS release.

You need to start over, do an install of Red Hat 5 update 2 and use a supported OS/software combination.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Sebastian Szewczyk
Frequent Advisor

Re: Linux Red Hat 5.3 (Tikanga) Qlogic Failover - boot from SAN

I read that I need VCS 4.x active/active but what can i do in situation when i can;t change my VCS i acn't updtae them because from this array i presenetd disk for Tru 64 v 5.1 which is not supported active/active.
Sebastian Szewczyk
Frequent Advisor

Re: Linux Red Hat 5.3 (Tikanga) Qlogic Failover - boot from SAN

Hello Steven

Do you think that when I downgrade my system to 5.2 version and install HPDMmultipath then will be work properly. I have VCS 3028.
What in that situation because i must to have failover and redundant.

best regards
seboizm
Ivan Ferreira
Honored Contributor

Re: Linux Red Hat 5.3 (Tikanga) Qlogic Failover - boot from SAN

>>> Tru 64 v 5.1 which is not supported active/active.

It is supported, we have it, the only problem is that Tru64 "may have perfomance degradation" as there will be proxy I/O according to HP whitepaper.

But, unless you explicitily set the controller owner for a vdisk, and set the preferred path from the O.S., you will have proxy I/O without knowing.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?